yorestov
?>

3.составить программу, которая устанавливала бы, является ли четырёхугольник со сторонами a, b, c, d параллелограммом. нужно

Информатика

Ответы

ruslanriad10
Pascal :
Код чтобы скопировать : http://rextester.com/EFBKO81416

3.составить программу, которая устанавливала бы, является ли четырёхугольник со сторонами a, b, c, d
olimov9
Язык C++.
#include < iostream >
using namespace std;
int main(){
int a, b, c, d, u;
cout << "Все четыре угла прямые (Да - 1/Нет - 0)?" << endl;
cin >> u;
switch(u){
case 0:{
cout << "Введите длины сторон: " << endl;
cin >> a >> b >> c >> d;
if((a==c && d == b) && (a==b && c==d)&&(a==d && b==c) &&(c==b && a == d))
cout << "Не параллелограмм";
else if((a==c && d == b) || (a==b && c==d)||(a==d && b==c) || (c==b && a == d))
cout << "Параллелограмм";
else
cout << "Не параллелограмм";
break;
}
case 1:{
cout << "Не параллелограмм";
}
}
}
Волков1968
Var a: byte; b:integer;
Begin 
writeln('Введите день месяца');
readln(b);
writeln('Введите номер месяца');   
Readln(a);    
          Case a of        
1: writeln(b,' янавря');        
2: writeln(b,' февраля');      
3: writeln(b,' марта ');        
4: writeln(b,' апреля ');      
5: writeln(b,' мая');      
6: writeln(b,' июня ');        
7: writeln(b,' июля');       
8: writeln(b,' августа');     
9: writeln(b,' сентября');     
10: writeln(b,' октября');     
11: writeln(b,' ноября');       
12: writeln(b,' декабря');     
else writeln('Месяца №', a,'нет');   
end;       
end.
vadim330
// PascalABC.NET 3.1, сборка 1200 от 13.03.2016

function gcd(a,b:integer):integer;
// Нахождение НОД
begin
  while b<>0 do
  begin
    a:=a mod b;
    var i:=b; b:=a; a:=i
  end;
  Result:=a
end;

procedure Shorter(var a,b:integer);
// "сокращатель" дроби
begin
  var k:=gcd(a,b);
  a:=a div k;
  b:=b div k
end;

begin
  var a,b:integer;
  Writeln('Введите числитель и знаменатель дроби: ');
  Read(a,b);
  Write(a,'/',b,'='); Shorter(a,b); Writeln(a,'/',b)
end.

Тестовое решение:
Введите числитель и знаменатель дроби:
25 15
25/15=5/3

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

3.составить программу, которая устанавливала бы, является ли четырёхугольник со сторонами a, b, c, d параллелограммом. нужно
Ваше имя (никнейм)*
Email*
Комментарий*