Nadegdasb
?>

Пользователь вводит с клавиатуры целые положительные числа большие 1, которые перемножаются в программе. составьте программу вычисляющую значение произведения вводимых значений. условием окончания ввода данных является ввод значения меньшего или равного 1. (сделать нужно через паскаль) 40 .

Информатика

Ответы

Liliya-buc
PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  ReadSeqIntegerWhile(t->t>1).Aggregate(BigInteger(1),(m,n)->m*n).Println
end.

Пример
3564
523
7
13632
634534
123236
342
1
4756807744621594586394624
kolyabelousow4059
Задача №1

var a:array[1..3, 1..4] of integer; 
i,j,min:integer; 
begin 
for i:=1 to 3 do 
for j:=1 to 4 do begin 
read(a[i,j]); 
if a[i,j]<0 then min:=a[i,j]; 
end; 
for i:=1 to 3 do 
for j:=1 to 4 do 
if (a[i,j]<0) and (a[i,j]<min) then min:=a[i,j]; 
writeln('Минимальное отрицательное число ',min); 
end.

Задача №2
var a:array[1..2, 1..5] of integer; 
i,j:integer; 
begin 
for i:=1 to 2 do 
for j:=1 to 5 do read(a[i,j]); 
for i:=1 to 2 do begin 
for j:=1 to 5 do 
write(a[i,j],' '); 
writeln; 
end; 
end. 

Задача №3
var a:array[1..3, 1..4] of integer; 
i,j:integer; 
begin 
for i:=1 to 3 do 
for j:=1 to 4 do read(a[i,j]); 
for i:=1 to 3 do 
for j:=1 to 4 do 
if a[i,j]=10 then writeln('Номер столбца — ',j,' Номер строки — ',i); 
end. 
marinavg63607
Эту колдунью зовут Кодировка КОИ-8. Таблица кодирования: А-Ю, Б-А, В-Б, Г-Ц, Д-Д, Е-Е, Ж-Ф, З-Г, И-Х, Й-И, К-Й, Л-К, М-Л, Н-М, О-Н, П-О, Р-П, С-Я, Т-Р, У-С, Ф-Т, Х-У, Ц-Ж, Ч-В, Ш-Ь, Щ-Ы, Ъ-З, Ы-Ш, Ь-Э, Э-Щ, Ю-Ч, Я-Ъ, Ё-╦ Таблица построена так. Слева стоят буквы по русскому алфавиту, а справа русские буквы, соответствующие английскому алфавиту. @ - Ю (код 40), A - А (41), B - Б, C - Ц, D - Д, E - E, F - Ф, и т.д. Буква Ё - 33-ья в алфавите, она выбивается из ряда в 32 буквы, поэтому превращается не в букву, а в элемент псевдографики. И еще меняется регистр, 1-ая буква маленькая, остальные большие.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Пользователь вводит с клавиатуры целые положительные числа большие 1, которые перемножаются в программе. составьте программу вычисляющую значение произведения вводимых значений. условием окончания ввода данных является ввод значения меньшего или равного 1. (сделать нужно через паскаль) 40 .
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

zrs-546
Марюк-Мубариз
sky-elena712558
alexfold
kattarina71
argent
Vetroff-11
chizhenkovd9
azelenkov
Yelizaveta555
Nikolaevna382
info7
evainvest1
Darya Aleksei1173
mmurzina