chetverikovalex3738
?>

Написать программу, которая находит одинаковые цифры двух чисел. в pascal, желательно через function. можно чтобы токого не было.входные данные: 466 476. выходные : 6 6. заранее

Информатика

Ответы

denisrogachv
PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!

function Duplicates(a,b:int64):array of char;
begin
  var ha:=a.ToString.ToHashSet;
  ha.IntersectWith(b.ToString.ToHashSet);
  Result:=ha.ToArray
end;  

begin
  var m,n:int64;
  Write('Введите через пробел два натуральных числа: ');
  Read(m,n);
  var r:=Duplicates(m,n);
  if r.Length=0 then Writeln('Нет цифр, встречающихся в обоих числах')
  else r.Println(',')
end.

Примеры
Введите через пробел два натуральных числа: 12345 6789067
Нет цифр, встречающихся в обоих числах

Введите через пробел два натуральных числа: 1342103 6748644
4

Реализация без множеств

procedure nToArray(n:int64; a:array of boolean);
begin
  for var i:=0 to 9 do a[i]:=False;
  if n=0 then a[0]:=True
  else
    while n>0 do begin
      a[n mod 10]:=True;
      n:=n div 10
      end
end;

function Duplicates(a,b:int64):array of boolean;
begin
  var ma:=new boolean[10];
  var mb:=new boolean[10];
  nToArray(a,ma);
  nToArray(b,mb);
  Result:=new boolean[10];
  for var i:=0 to 9 do
    Result[i]:=ma[i] and mb[i]
end; 

begin
  var m,n:int64;
  Write('Введите через пробел два натуральных числа: ');
  Read(m,n);
  var r:=Duplicates(m,n);
  Write('Совпадающие цифры: ');
  for var i:=0 to 9 do
    if r[i] then Write(i,' ');
  Writeln
end.

Пример
Введите через пробел два натуральных числа: 12352423 98789635233
Совпадающие цифры: 2 3 5
Bella
Что значит увеличения и уменьшения информации слабо как то понимаю, примеры вообще простые - Бобер Александр собрал палки хворост и всякую мелочь которая хаотично лежала где то там, и сделал из нее плотину, вполне, кстати говоря, порядочную. 
А наоборот и будет ответ на второй вопрос, пускай молния ударить в плотину нашего многоуважаемого Александра, и уже порядочная плотина превращается в мусор разбросанный где то там и слегка горящий.
Что касается последнего пункта, то похоладало, какая нить птица заметила это сообщила стае, и вместе они решили улететь перезимовать это дело...
Николаевна

1)Если насыпать железную стружку на дощечку, под которой магнит, то стружка из перемешанного состояния структурируется в линии.
2)Например в герментичной ёмкости с двумя газами вскоре они переместятся и будет более неоднородная смесь. Также, например, при взрыве чего-либо сложная структура ломается. При ядерном взрыве тяжёлые сложные элементы распадаются на более мелкие.
3)Например из семечка вырастает дерево, а дерево имеет более сложную структуру, чем семечко. Аналогично с животными, например из яйца вылупляется цыплёнок. Также в ходе эволюции из одноклеточных организмов появились рыбы, у которых струтура намеого сложнее чем у одноклеточных организмов.
4)Получение: при глаз(зрение), носа(обояние), ушей(слух), вистибулярного опарата(положение в пространстве) и др. у млекопитающих и других относительно развитых организмов.
  У клеток при химических реакций.
  Передача:

 Многие млекопитающие издают звуки(кошки мяукают, птицы чирикают) оповещая своих сородичей, например, об обастности или о еде и др.
  Также через гены(мутации, эволюция).
  Использование: чтобы добывать пищу от опасности стае, заботится о детях, оринтироваться в пространстве.
5)Человек также, кроме того, что могут многие млекопитающие(слух, зрение и т.д.), может читать(зрение), определять север при компаса(зрение), сотреть на карту(зрение), слушать речь(в отличии от животных речь человека очень развита и передаёт в разы больше информации)(слух) и т.д..
6)Язык, на котором написано сообщение, должнен быть понятным для приёмника(русский, английский или какой-нибудь другой язык для человека, протокол общения для сервера)
7)Знания также должны быть понятны, но ещё посны и точны.
8)СМИ должны довать достоверную, понятную и полезную(актуальную) информацию.
9)Роботы, беспилотные летательные опараты(информация: о положении и курсе. команды: движения закрылок), марсоходы(информация: о приказе, изображение с камер и данные датчиков, команды: движения манипуляторов и колёс), система климат-контроля в машинах(информация: о температере, влажности и выбранном режиме работы, команды: включения/выключения нагреватель и открытия/закрытия воздухозаборников)
Микроволновка(информация: о режиме работы и оставшимся времени, команды: греть/негреть, крутить/некрутить и пикнуть)
10)на производстве роботы делают машины, паяют микросхемы, вытачивают мелкие детали. На марсе марсоходы иследуют марс.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая находит одинаковые цифры двух чисел. в pascal, желательно через function. можно чтобы токого не было.входные данные: 466 476. выходные : 6 6. заранее
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

borisov
ВасилийКлимова1695
gub191025
kronid12
ehrik-ch
kirieskamod262
dailyan539
krasnova1977
Sharmel26
juliajd
Anna-Miron
Динков
kzhgutova
libirishka7910
Кириллов57