karpovaveronika196
?>

1) составьте программу вычисления значения функции y по формуле y= sin x+1/x, для которой значение аргумента x ведите с клавиатуры. отладьте программу на следующем примере: x=5 y=-0, 758924

Информатика

Ответы

avguchenkov
П0 sin ИП0 1/x + С/П

Для значения 5 выдаёт "-7,5892425  -1".
Aleksandrovich1669
Double x,y;
cin>>x;
y= sin(x)+1/x;
cout<<y;

это на с++
отладить можно в visual studio
qt creator
Викторовна
По выполняемым функциям и возможности применения информационные технологии делят на используемые:1) в автономных компьютерах (ПЭВМ) и в локальных рабочих станциях (АРМ) в составе сетевых автоматизированных информационных систем (АИС) реального времени;2) в объектно-ориентированных, распределённых, корпоративных и иных локальных и сетевых информационно-поисковых, гипертекстовых и мультимедийных системах;3) в системах с искусственным интеллектом;4) в интегрированных АИС;5) в геоинформационных, глобальных и других системах.
Роман Александр66
Выполняя алгоритм, получаем следующий результат (15 итераций)

1. 0..65534 -> 32767
2. 0..32766 -> 16383
3. 0..16382 -> 8191
4. 0..8190  -> 4095
5. 0..4094  -> 2047
6. 2048..4094 -> 3071
7. 2048..3070 -> 2559
8. 2560..3070 -> 2815
9. 2816..3070 -> 2943
10. 2944..3070 -> 3007
11. 2944..3006 -> 2975
12. 2976..3006 -> 2991
13. 2992..3006 -> 2999
14. 3000..3006 -> 3003
15. 3000..3002 -> 3001

Если лень перебирать вручную, можно воспользоваться программой

var k,l,r,x,f:integer;
begin
f := 3001;
l := 0;
r := 65534;
x := (l + r) div 2;
k := 1;
while (x <> f) and (l < r) do
  begin
  writeln(k,' ',l,' ',r,' ',x);
  k := k + 1;
  if f < x then r := x - 1
    else l := x + 1;
  x := (l + r) div 2
  end;
writeln(k,' ',l,' ',r,' ',x);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1) составьте программу вычисления значения функции y по формуле y= sin x+1/x, для которой значение аргумента x ведите с клавиатуры. отладьте программу на следующем примере: x=5 y=-0, 758924
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

cheberyako2013
vikka30
nnbeyo
vikgor45
uttgroup
Kochinev4
anastasiaevent4
Alyona1692
maxkuskov2485
АркадьевичБундин789
Быстренько надо это решить
Александрович175
Вера1072
manuchar-formen2
arturusinsk5
Galkin Vladimirovich729