Бражинскене_Алексей
?>

Написать программу, используя динамическое выделение памяти. дан массив а из n целых чисел. вывести на печать только те числа, для которых выполняется условие аi ≤ i, где i – номер элемента массива

Информатика

Ответы

МуратМарина1140
PascalABC.NET 3.3.5, сборка 1660 от 20.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),0,30); a.Println;
  for var i:=0 to a.Length-1 do
    if a[i]<=i+1 then Print(a[i])
end.

Пример
n= 20
18 19 0 24 24 19 15 1 25 11 15 19 15 12 2 2 7 19 20 12
0 1 12 2 2 7 12
Adno1578
ОТДЕЛ Задание+;
ИСПОЛЬЗУЕТ
  Матем ИЗ "...\Отделы\Обмен\",
  Вывод ИЗ "...\Отделы\Обмен\",
  Приём ИЗ "...\Отделы\Обмен\";

ПЕР
  A: ДОСТУП К РЯД ИЗ ЦЕЛ;
  N, сч: ЦЕЛ;

УКАЗ
  N := Приём.Число();
  СОЗДАТЬ(A, N);
  ОТ сч := 0 ДО N - 1 ВЫП
    A[сч] := УЗК(ВШИРЦЕЛ(Матем.случ() * N))
  КОН;

  ОТ сч := 0 ДО N - 1 ВЫП
    ЕСЛИ A[сч] <= сч ТО
      Вывод.ЧЦел("%d ", A[сч], 0, 0, 0)
    КОН
  КОН

КОН Задание.
myrisik2490
Задание 1.

Для ка­ко­го из приведённых чисел ис­тин­но высказывание: НЕ (число < 20) И (число нечётное)?

НЕ (число < 20) И (число нечётное)

(число > = 20) И (число нечётное)

8 - не подходит, меньше 20

15 - не подходит, меньше 20

21 - подходит

36 - не подходит, четное

ответ - 3) 21

Задание 2.

Для ка­ко­го из приведённых чисел ложно высказывание  НЕ (число > 50) ИЛИ (число чётное)?

НЕ (число > 50) ИЛИ (число чётное)

(число = < 50) ИЛИ (число чётное)

т.к. высказывание должно быть ложным, то обе части должны быть ложны, т.е.

(число > 50) И (число нечётное)

123 - подходит

56 - не подходит, четное

9 - не подходит, меньше 50

8 - не подходит, меньше 50

ответ - 1) 123

Задание 3.

Для ка­ко­го из приведённых имён ложно высказывание:  НЕ (Первая буква гласная) ИЛИ НЕ (Последняя буква согласная)?

НЕ (Первая буква гласная) ИЛИ НЕ (Последняя буква согласная)

(Первая буква согласная) ИЛИ (Последняя буква гласная)

т.к. высказывание должно быть ложным, то обе части должны быть обе ложными, т.е.

(Первая буква гласная) И (Последняя буква согласная)

Эдуард - подходит

Ангелина - не подходит, последняя буква гласная

Карина - не подходит, первая буква согласная

Никон - не подходит, первая буква согласная

ответ - 1) Эдуард

Задание 4.

Для ка­ко­го из приведённых имён ложно высказывание:  НЕ ((Первая буква гласная) И (Последняя буква согласная))?

НЕ ((Первая буква гласная) И (Последняя буква согласная))

(Первая буква согласная) И (Последняя буква гласная)

т.к. высказывание должно быть ложным, то обе части должны быть обе ложными, т.е.

(Первая буква гласная) И (Последняя буква согласная)

Валентина - не подходит, первая буква согласная

Герман - не подходит, первая буква согласная

Анастасия - не подходит, последняя буква гласная

Яков - подходит

ответ - 4) Яков

Задание 5.

Для ка­ко­го из дан­ных слов ис­тин­но высказывание:  (ударение на пер­вый слог) И НЕ (количество букв чётное)?

(ударение на пер­вый слог) И НЕ (количество букв чётное)

(ударение на пер­вый слог) И (количество букв нечётное)

корова - не подходит, ударение на второй слог

козёл - не подходит, ударение на второй слог

кошка - подходит

конь - не подходит, кол-во букв чётное

ответ - 3) кошка

Задание 6.

Для ка­ко­го из приведённых чисел ложно высказывание: НЕ (число > 30) ИЛИ (число чётное)?

НЕ (число > 30) ИЛИ (число чётное)

(число = < 30) ИЛИ (число чётное)

т.к. высказывание должно быть ложным, то обе части должны быть обе ложными, т.е.

(число > 30) И (число нечётное)

28 - не подходит, меньше 30

34 - не подходит, чётное

17 - не подходит, меньше 30

45 - подходит

ответ - 4) 45

Задание 7.

Для ка­ко­го из приведённых чисел ис­тин­но высказывание:  НЕ (число > 10) И (число нечётное)?

НЕ (число > 10) И (число нечётное)

(число = < 10) И (число нечётное)

22 - не подходит, больше 10

13 - не подходит, больше 10

9 - подходит

6 - не подходит, чётное

ответ - 3) 9

Задание 8.

Для какой из пе­ре­чис­лен­ных ниже фа­ми­лий рус­ских пи­са­те­лей и поэтов ис­тин­но высказывание:  НЕ (количество глас­ных букв нечётно) И НЕ (первая буква согласная)?

НЕ (количество глас­ных букв нечётно) И НЕ (первая буква согласная)

(количество глас­ных букв чётно) И (первая буква гласная)

Есенин - не подходит, нечётно кол-во гласных

Одоевский - подходит

Толстой - не подходит, первая согласная

Фет - не подходит, первая согласная

ответ - 2) Одо­ев­ский

Задание 9.

Для ка­ко­го из приведённых зна­че­ний числа X ложно высказывание: НЕ (X = 5) ИЛИ (X > 6)?

НЕ (X = 5) ИЛИ (X > 6)

(X <> 5) ИЛИ (X > 6)

т.к. высказывание должно быть ложным, то обе части должны быть обе ложными, т.е.

(X = 5) ИЛИ (X < 6)

4 - не подходит

5 - подходит

6 - не подходит

7 - не подходит

ответ - 2) 5

Задание 10.

Для ка­ко­го из дан­ных слов ис­тин­но высказывание  НЕ (третья буква гласная) И (последняя согласная)?

НЕ (третья буква гласная) И (последняя согласная)

(третья буква согласная) И (последняя согласная)

слива - не подходит, третья буква гласная

инжир - подходит

ананас - не подходит, третья буква гласная

киви - не подходит, последняя буква гласная

ответ - 2) инжир

uisfbu7777733
С++
#include <iostream>
#include <ctime>
using namespace std;
int main ()
{
setlocale (0,"russian");
srand (time(NULL));
int N;
cout << "Чётное N=";
cin >> N;
if (N%2==0 && N>0)
{
int *arr=new int [N];
cout << "Случайный массив: ";
for (int i=0;i<N;i++)
{
arr[i]=rand()%200-100;
cout << arr[i] << ' ';
}
cout << endl << "Итог: ";
for (int x=N/2-1;x>=0;x--)
cout << arr[x] << ' ';
for (int y=N-1;y>=N/2;y--)
cout << arr [y] << ' ';
}
else
cout << "Ошибка!";
system ("PAUSE>>VOID");
return 0;
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, используя динамическое выделение памяти. дан массив а из n целых чисел. вывести на печать только те числа, для которых выполняется условие аi ≤ i, где i – номер элемента массива
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

amarantmetall
petrova-kate3
Daletskaya Sergei1121
compm
elyashatdinova
apioslk4533
achernakov
metegina4
arnaut-anna
zakaz
slava-m-apt
sttig
ibombenkova
Jannadon77
magazin3000