kris5009646
?>

Даны три положительных числа a, b, c. пусть x - количество десятков в числе r =[tex]a^2 + b^2+ c^2 используя оператор case составить программу для вычисления f(x

Информатика

Ответы

ольга1801
Type
  Point=record
    x,y:real
    end;

procedure GetPoint(c:char; var A:Point);
  var
    x,y:real;
begin
  Write('Введите координаты x и y точки ',c,': ');
  Read(x,y);
  A.x:=x; A.y:=y
end;

function DistPoint(A,B:Point):real;
begin
  DistPoint:=sqrt(sqr(B.x-A.x)+sqr(B.y-A.y))
end;

var
  A,B,M:Point;
  d,p,ab,ma,mb:real;
begin
  GetPoint('A',A); GetPoint('B',B); GetPoint('M',M);
  ab:=DistPoint(A,B); ma:=DistPoint(M,A); mb:=DistPoint(M,B);
  if ma>=ab+mb then d:=mb
  else
    if mb>=ma+ab then d:=ma
    else begin
      p:=(ma+mb+ab)/2;
      d:=2*sqrt(p*(p-ab)*(p-ma)*(p-mb))/ab
    end;
  Writeln('Минимальное расстояние составляет ',d)
end.

Тестовое решение:
Введите координаты x и y точки A: -3 -5
Введите координаты x и y точки B: 2 5
Введите координаты x и y точки M: -3 4
Минимальное расстояние составляет 4.02492235949962
dmdlir
Const nx=30;mx=30;
var i,j,n,m:integer;A:array[1..nx,1..mx] of integer;B,D:array[1..nx] of integer;
begin 
write('Введите n');Readln(n);
write('Введите m');Readln(m);
for i:=1 to n do begin
for j:=1 to m do вegin
A[i,j]:=random(100)-20;
write(A[i,j]:4);end;writeln;end;writeln;
for i:=1 to n do begin
for j:=1 to m do begin
if (A[i,j] mod 3 =0) then begin
B[i]:= B[i] + A[i,j];write(A[i,j]:4);D[i]:= D[i] + 1;end;end;writeln;end;
for i:=1 to n do begin
if (B[i]=0) and (D[i]= 0) then B[i]:= -10;
write(B[i]:4);end;end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Даны три положительных числа a, b, c. пусть x - количество десятков в числе r =[tex]a^2 + b^2+ c^2 используя оператор case составить программу для вычисления f(x
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Палкина-Дроздова
Narine natalya
jardi
suhovaab
karkh267
Pochkun-Oleg
Константин
yna21289
astahova
ambstroy
Lapushkin1988
Yumashev
sergey3699
Petrosienko_Larisa,1908
Ainura Pokhomova