Stasyadoma
?>

На питоне дано натуральное число n. напишите функцию int mindigit (int n) (c/c++), function mindigit (n: longint): integer (pascal) и int maxdigit (int n) (c/c++), function maxdigit (n: longint): integer (pascal), определяющую наименьшую и наибольшую цифры данного числа. входные данные задано единственное число n выходные данные необходимо вывести наименьшую и наибольшую цифры данного числа через пробел.

Информатика

Ответы

Darya Aleksei1173

низн Прадо самой нужно сделайте

Reginahappy
#include <iostream>#include <ctime>//Бібліотека для рандомуusing namespace std;int main(){ int array[10];//Масив int Max_Num=0,Min_Num=0;// Мінімальне і Максимальне числа bool Positive_or_negative=0;//Число додатнє чи відємне srand(time(NULL));//Рандом.Кожний раз інший. for(int i=0;i<10;++i) { Positive_or_negative=rand()%2; if(Positive_or_negative==false)//якщо Positive_or_negative==0 { array[i]=-(rand()%10);//Рандом від -10...0 } else { array[i]=rand()%10;//Рандом від 0...10 } if(array[i]>Max_Num)//Пошук макс. числа { Max_Num=array[i]; } if(array[i]<Min_Num)//Пошук Мін. числа { Min_Num=array[i]; } cout<<array[i]<<" "; } cout<<endl<<"Max. number is:"<<Max_Num<<endl;//Вивід максимально числа cout<<"Min. number is:"<<Min_Num<<endl;//Вивід мінімально числа system("pause>>void");//закінчення программи.}
agrilandrussia
1 фото в порядке убывания
2 в порядке возрастания

тебе надо 2:

Program Rick_and_Morty;
var x,y,z:integer;

Begin
write('введите 1 число: ');
readln (x);
write('введите 2 число: ');
readln (y);
write('введите 3 число: ');
readln (z);

if ((x<=y) and (x<=z))then
  begin    if (y<=z) then
  writeln(x,',',y,',',z)  
  else
  writeln(x,',',z,',',y);
    end
else

if ((y<=x) and (y<=z))then
  begin
  if (x<=z) then
  writeln(y,',',x,',',z)
  else
  writeln(y,',',z,',',x)
  end
else

if ((x<=y)) then
  writeln(z,',',x,',',y)
  else
  writeln(z,',',y,',',x);

writeln('конец');
end.
Напишите программу запрашивающую 3 числа и выводящую их в порядке возрастания.
Напишите программу запрашивающую 3 числа и выводящую их в порядке возрастания.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

На питоне дано натуральное число n. напишите функцию int mindigit (int n) (c/c++), function mindigit (n: longint): integer (pascal) и int maxdigit (int n) (c/c++), function maxdigit (n: longint): integer (pascal), определяющую наименьшую и наибольшую цифры данного числа. входные данные задано единственное число n выходные данные необходимо вывести наименьшую и наибольшую цифры данного числа через пробел.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Petrushin482
Васильева-Александрович
Rubber-soul
Maionova
olgapotapova
Марина566
andreykrutenko
vorota-grupp
arturcristian
Galina3241
arutchevben64
Yelizaveta555
emik071089
annashaykhattarova1
werda84
▲