konnovakat1
?>

На вас вся ! информатика 8 класс! ! напишите программу, которая вычисляет площадь и периметр прямоугольника по длинам двух его сторон.

Информатика

Ответы

ledlenta751
Var
    a, b: real;

begin
    readln(a, b);
    writeln('S=', a * b);
    writeln('P=', 2 * (a + b));
end .

Мне это мама сказала если что-то не правильно скажи,исправлю
shutovaa3471

using System;

public class Program

{

public static void Main()

{

 /*Даны два целых числа: D (день) и M (месяц),  

 определяющие правильную дату невисокосного года. Вывести значения D и M для даты, следующей за указанной. */

 int D = Convert.ToInt32(Console.ReadLine());

 int M = Convert.ToInt32(Console.ReadLine());

 switch (M)

 {

  case 1:

  case 3:

  case 5:

  case 7:

  case 8:

  case 10:

   if (D == 31)

   {

    Console.WriteLine(D = 1);

    Console.WriteLine(M = M + 1);

    break;

   }

   else if (D > 31)

   {

    Console.WriteLine("Такой даты нет!");

    break;

   }

   else

   {

    Console.WriteLine(D + 1);

    Console.WriteLine(M);

    break;

   }

  case 2:

   if (D == 28)

   {

    Console.WriteLine(D = 1);

    Console.WriteLine(M = M + 1);

    break;

   }

   else if (D > 28)

   {

    Console.WriteLine("Такой даты нет!");

    break;

   }

   else

   {

    Console.WriteLine(D + 1);

    Console.WriteLine(M);

    break;

   }

  case 4:

  case 6:

  case 9:

  case 11:

   if (D == 30)

   {

    Console.WriteLine(D = 1);

    Console.WriteLine(M = M + 1);

    break;

   }

   else if (D > 30)

   {

    Console.WriteLine("Такой даты нет!");

    break;

   }

   else

   {

    Console.WriteLine(D + 1);

    Console.WriteLine(M);

    break;

   }

  case 12:

   if (D == 31)

   {

    Console.WriteLine(D = 1);

    Console.WriteLine(M = 1);

    break;

   }

   else if (D > 31)

   {

    Console.WriteLine("Такой даты нет!");

    break;

   }

   else

   {

    Console.WriteLine(D + 1);

    Console.WriteLine(M);

    break;

   }

 }

}

}

Объяснение:

parolmm

Відповідь:

Арифметические выражения

Вспомним оператор присваивания. Общий вид можно записать таким образом:

имя_переменной = выражение  

Выражение, стоящее в правой части оператора присваивания, позволяет вычислять значения переменных по различным формулам.

 

Выражение может содержать:

• целые и вещественные числа (в вещественных числах целая и дробная часть разделяются точкой, а не запятой, как это принято в математике)

• знаки арифметических действий:  

+ сложение,

- вычитание,

* умножение,

/ деление

**возведение в степень;

• вызовы стандартных функций (приведем только часть из большого набора. Все математические функции описаны в библиотеке math, которую необходимо подключить с использованием строки import math )

abs(n) модуль целого числа n

math.fabs(x) модуль вещественного числа x  

math.sqrt(x) квадратный корень из вещественного числа x

math.pow(x,y) вычисляет x в степени y;

Пояснення:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

На вас вся ! информатика 8 класс! ! напишите программу, которая вычисляет площадь и периметр прямоугольника по длинам двух его сторон.
Ваше имя (никнейм)*
Email*
Комментарий*
▲