serg1976g
?>

Через паскаль! тема: «поиск наибольшего или наименьшего элемента массива» написать программу, которая запрашивает у пользователя строку и заменяет в ней все пробелы знаками подчеркивания '_' не использовать: const, count и другие, которые не по теме!

Информатика

Ответы

serebrennikova99
Var i: Integer;
s: String;
begin
writeln('Введите текст');
readln(s);
for i:=1 to Length(s) do
begin
if s[i]=' ' then s[i]:='_';
end;
writeln(s);
end.
colus77
Var
    g: string;
    i: byte;
begin
    readln(g);
    i := 1;
    while g[i] = ' ' do delete(g,i,1);
    i := length(g);
    while g[i] = ' ' do begin delete(g,i,1); i := i - 1 end;
    i := 1;
    while i <= length(g) do begin
  if g[i] = ' ' then
   if g[i-1] = '*' then begin
    delete(g,i,1);
    i := i - 1;
   end
   else begin
    delete(g,i,1);
    insert('_',g,i);
   end;
  inc(i);
    end;
    writeln(g);
end.
Bordo

115₁₀ = 1110011₂

а) 1001111₂ = 79₁₀

б) 356₈ = 238₁₀

в) 24С₁₆ = 588₁₀

543₈ → 355₁₀ → 163₁₆

Объяснение:

115 / 2 = 57 + остаток 1

57 / 2 = 28 + остаток 1

28 / 2 = 14 + остаток 0

14 / 2 = 7 + остаток 0

7 / 2 = 3 + остаток 1

3 / 2 = 1 + остаток 1

1 / 2 = 0 + остаток 1

записываем остатки снизу вверх

115₁₀ = 1110011₂

а) 1001111₂ = 1 * 2⁶ + 0 * 2⁵ + 0 * 2⁴ + 1 * 2³ + 1 * 2² + 1 * 2¹ + 1 * 2⁰ = 64 + 8 + 4 + 2 + 1 = 79₁₀

б) 356₈ = 3 * 8² + 5 * 8¹ + 6 * 8⁰ = 3 * 64 + 5 * 8 + 6 * 1 = 192 + 40 + 6 = 238₁₀

в) 24С₁₆ = 2 * 16² + 4 * 16¹ + С * 16⁰ = 2 * 256 + 4 * 16 + 12 * 1 = 512 + 64 + 12 = 588₁₀

В качестве цифр шестнадцатеричной системы счисления обычно используются цифры от 0 до 9 и латинские буквы от A до F.

A = 10₁₀     В = 11₁₀   С = 12₁₀   D = 13₁₀   Е = 14₁₀   F = 15₁₀

543₈ = 5 * 8² + 4 * 8¹ + 3 + 8⁰ = 5 * 64 + 4 * 8 + 3 * 1 = 320 + 32 + 3 = 355₁₀

355 / 16 = 22 + остаток 3

22 / 16 = 1 + остаток 6

1 / 16 = 0 + остаток 1

записываем остатки снизу вверх

355₁₀ = 163₁₆

leonid-adv70

Цель работы: изучить основные блоки и периферийные устройства персонального компьютера их соединения, конструктивы (разъемы), основные характеристики (название, тип разъема, количество контактов, скорость передачи данных, дополнительные свойства); научиться определять по внешнему виду типы разъемов, подключаемое к ним оборудование, знать основные устройства персонального компьютера, их назначение и основные характеристики; научиться определять компоненты системного блока по внешнему виду, уяснить порядок и их соединения.

Бюджет времени: 2 часа.

Оборудование: системный блок, кабели в комплекте, монитор, клавиатура, периферийные устройства для различных разъемов (мышь, принтер, модем и др.), системный блок в сборе, макеты видеоадаптера, материнской платы, корпуса, жесткого диска, накопителя на флоппи-дисках, интерфейсные кабели.

Краткие теоретические сведения

В основу устройства компьютера положен принцип открытой архитектуры, т.е. возможность подключения к системе дополнительных независимо разработанных устройств для различных прикладных применений. Все устройства подключаются к системе и взаимодействуют друг с другом через общую шину.

Минимальный набор аппаратных средств, без которых невозможен запуск, и работа ПК определяет его базовую конфигурацию. В базовую конфигурацию ПК входят: системный блок, монитор, клавиатура и ручной манипулятор – мышь. Включение ручного манипулятора в базовую конфигурацию обусловлено тем, что работа в современных графических операционных системах без этого устройства возможна, но крайне затруднительна.

 

Системный блок. Системный блок является центральной частью ПК. В корпусе системного блока размещены внутренние устройства ПК.

Системные блоки ПК имеют различные дополнительные элементы (вентилятор, динамик) и конструктивные особенности, обусловленные назначением и условиями эксплуатации ПК. Обязательным узлом системного блока является блок питания, который преобразует поступающий из сети переменный ток напряжением 220В в постоянный -3.3В, -5В и -12В для электропитания всех внутренних устройств компьютера. Основным параметром блока питания, учитываемым при сборке требуемой конфигурации ПК, является его мощность. Питание монитора также возможно через блок питания системного блока.

 

По внешнему виду системные блоки отличаются формой корпуса (рис. 3). Наиболее распространенными на сегодняшний день являются системные блоки форм-фактора АТХ (на следующем практическом занятии рассмотрим особенности конструкции системных блоков нового перспективного форм-фактора – ВТХ).

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Через паскаль! тема: «поиск наибольшего или наименьшего элемента массива» написать программу, которая запрашивает у пользователя строку и заменяет в ней все пробелы знаками подчеркивания '_' не использовать: const, count и другие, которые не по теме!
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

arina2403423
smartschoolfili6
zabava-83
Головин662
andreevaalisa
chapaevval
ivanovk3599
vodexshop2
zoomagazinkotmatroskin
КириллЕгорова1906
shoko91
zinasekina4
delfinmos
milenaochirova01017424
jenn055