zakupki
?>

На предприятии за одну смену выпускается х планшетов. известно, что p% из них в черном корпусе, а остальные в белом. написать программу для вычисления количества белых планшетов, выпускаемых за смену на предприятии.формула

Информатика

Ответы

olgusikok
Сделано в Pascal ABC:

Program White;
var  X, P, Y: real;
begin 
writeln('Введите количество всех планшетов'); 
readln(X);   
writeln('Введите Р процентов планшетов в черном корпусе'); 
readln(P); 
Y:=X-(X*(P/100)); 
writeln('Планшетов в белом корпусе=',Y)
end.
Yelfimova-andrei

from random import randint

# Создание списка,

# его сортировка по возрастанию

# и вывод на экран

a = []

for i in range(10):

   a.append(randint(1, 50))

a.sort()

print(a)

# искомое число

value = int(input())

mid = len(a) // 2

low = 0

high = len(a) - 1

while a[mid] != value and low <= high:

   if value > a[mid]:

       low = mid + 1

   else:

       high = mid - 1

   mid = (low + high) // 2

if low > high:

   print("Такого значения нет")

else:

   if (mid == 0 and a[1] != a[0]) or (mid == len(a) - 1 and a[mid - 1] != a[mid]):

       print(1)

   else:

       q = 0

       for i in range(mid, len(a)):

           if a[i] == a[mid]:

               q += 1

           else:

               break

       for i in range(mid - 1, 0, -1):

           if a[i] == a[mid]:

               q += 1

           else:

               break

       print(q)

Чтобы убрать вывод массива просто на 10-й строке убери print(a), а для  вывода неотсортированного массива вставь после 8-й строки.

yurogov61

Первый шаг в отношениях между пользователем и программой –  это запуск программы пользователем. Затем можно выполнять в программе те действия, ради которых она и была создана.

Объяснение: Рассмотрим запуска программ:

 1)Из Главного меню можно запускать программы, которые в нем записаны.

Для примера возьмем стандартные программы. Дело в том, что Windows – не просто операционная система. В ее состав входит множество разнообразных прикладных программ или, как их называют приложений, такие как

калькулятор,графический редактор Paint,текстовые редакторы Блокнот и WordPad,служебные программы по обслуживанию дискаи др.

Стандартные программы в главном меню Windows XP

Эту группу программ называют Стандартные, потому что она входит в состав операционной системы и устанавливается вместе с установкой операционной системы.

Чтобы запустить, например, Калькулятор, надо пройти по маршруту: кнопка Пуск – Программы – Стандартные – название программы (“Калькулятор”).

2) При двойного щелчка по значку программы или по ярлыку на Рабочем столе Windows.

3) Щелчок по значку программы  в Панели задач Windows. Например, на рисунке после щелчка по значку будет открыт текстовый редактор MS Word.

4) При команды “Выполнить” в Главном меню Windows.

В открывшемся окне Запуск программы нужно указать открываемый файл, причем можно воспользоваться для этого кнопкой Обзор, которая откроет окно просмотра содержимого дисков и папок. В нем, открывая папки, нужно выделить и открыть запускающий файл программы. По умолчанию во всех папках будут показаны только запускающие и командные файлы, а также ярлыки.

5) Автоматический запуск программ, например:

при начальной загрузке Windows. Для того, чтобы это сделать, следует пройти по маршруту Пуск – Программы – Автозапуск.

Если поместить программы в меню Автозагрузка, то они будут автоматически запущены при начальной загрузке Windows.

при вставке в дисковод CD или DVD диска. При этом автоматически запускается программа, записанная на диске, правда, если автором диска не предусмотрено иное действие.

Иногда для избежания заражения вирусом автоматический запуск компакт-дисков отключают и сначала проверяют диск антивирусом.

по заданному графику. Такую возможность предоставляет встроенная в Windows программа-планировщик.

6) Двойной щелчок по значку или по имени программы в окне “Мой компьютер” или “Проводник”.

7) Двойной щелчок по значку или имени документа, обрабатываемого той или иной программой. Например, если щёлкнуть по значку с буквой «W», запустится программа MS

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

На предприятии за одну смену выпускается х планшетов. известно, что p% из них в черном корпусе, а остальные в белом. написать программу для вычисления количества белых планшетов, выпускаемых за смену на предприятии.формула
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

annino
fialkaflowers77
snopovajulia
bulenbeiser
Семеновна-Павел
Natalya1895
Галина-Юлия1292
inessa12006
Sergei_Olga658
Lugovoi
dmitrievanata83538
natalia-shelkovich
myhauz
ksoboleva
tenvalerij