VolkovaMaslova
?>

Напишите программу. с начала суток секунд (n - целое найти количество полных часов, минут, секунд с начала суток. ввод - 24985 вывод - 6 ч 56 мин 25 сек язык с++

Информатика

Ответы

koll23
#include <iostream>
using namespace std;

int main () {
    int n;
    cin >> n;
    cout << n / 3600 << " ч ";
    n -= (n / 3600) * 3600;
    cout << n / 60 << " мин ";
    n -= (n / 60) * 60;
    cout << n << " сек ";
    return 0;
}
macmakka

Т.к. требуется использовать цикл until, то значит требуется код на языке Паскаль.

1) цикл for

program p_for

var

  p:  real;

  i, n: integer;

begin

  readln(n);

  p := 1;//начальное значение

  for i := 1 to n do  

     p := p * i;

  writeln(p);

end.  

2) цикл while

program p_while

var

  p:  real;

  i, n: integer;

begin

  readln(n);

  i := 1;

  p := 1;//начальное значение

  while i <= n do  

  begin

     p := p * i;

     i := i + 1;

 end;

 writeln(p);

end.  

3) цикл until

program p_until

var

  p:  real;

  i, n: integer;

begin

  readln(n);

  i := 1;

  p := 1;//начальное значение

  repeat

     p := p * i;

     i := i + 1;

  until i > n;

  writeln(p);

end.  

Объяснение:

Оксана Николаевич

7. 3

8. 2

Объяснение:

7.Мы ищем высказывание, которое не подходит к условию

длина отрезка больше 6 ИЛИ не все принадлежащие отрезку числа положительные.

1.[-10;-6] - длина отрезка больше 6, условие выполнено.

2.[-3; 1] - не все принадлежащие отрезку числа положительные, условие выполнено.

3.[7; 10] - все числа принадлежащие отрезку положительные, длина больше 6, условия не выполнены.

4.[3; 11] - длина отрезка больше 6, условие выполнено.

8. Мы ищем высказывание, которое не подходит к условию

все числа принадлежащие отрезку отрицательные ИЛИ длина отрезка меньше 5

1.[6; 10] - длина меньше 5, условие выполнено.

2.[-2; 4] - длина больше 5, не все числа отрицательные, условия не выполнены.

3.[-15; -5] - все числа отрицательные, условие выполнено.

4.[-7; -3] - все числа отрицательные, условие выполнено.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу. с начала суток секунд (n - целое найти количество полных часов, минут, секунд с начала суток. ввод - 24985 вывод - 6 ч 56 мин 25 сек язык с++
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

academycoffee243
kattarina71
julya847
tushina2020
avguchenkov
Taurus59707
a1rwalk3r
stsnab
mupmalino2653
skvorec3424
sorokinae
r682dm2011
Galina3241
petrova-kate3
Sergei1805