Код на Java:
import java.util.Scanner;
public class Znanija{
public static void main(String args[]) {
double number;
Scanner input = new Scanner(System.in);
System.out.println("Enter the number: ");
number = input.nextInt();
if(number>100) {
System.out.println("\nThe entered number is greater than 100, so we divide by 10: " + number/10);
}
else {
System.out.println("\nThe entered number is less than 100, read its square, and multiply by 100: " + Math.pow(number, 2)*100);
}
}
}
Псевдокод:integer number
print("Enter the number: ")
input.number
if number>100
print("The entered number is greater than 100, so we divide by 10: ", number/10)
else
print("The entered number is less than 100, read its square, and multiply by 100: ", number*number*100)
Поделитесь своими знаниями, ответьте на вопрос:
1.написать программу, которая определяет наибольшее отрицательное целое число в массиве из 10 элементов. значения элементов массива вводятся пользователем. 2.написать программу, которая определяет наибольшее по модулю число в массиве из 10 введенных пользователем чисел.
var
mas: array[0..10] of Integer ;
i,min,j: Integer;
begin
min:=0;
writeln('Введите числа:');
for i := 1 to 10 do begin
ReadLn(mas[i]);
if (mas[i] <0)
then j:=mas[i];
if j then min:=j;
end;
WriteLn('Минимальное отрицательное число:',min);
end.
2.
var
mas: array [0..10] of Integer;
i, max, j: Integer;
begin
writeln('Введите числа:');
for i := 1 to 10 do
begin
ReadLn(mas[i]);
if abs(mas[i - 1]) < abs(mas[i]) then
max := mas[i] ;
end;
WriteLn('Наибольшее по модулю число:', max);
end.