makeeva-nataliya60
?>

Написать программу в питоне напишите программу которая вычисляет выражение, состоящее из трех чисел и двух знаков (допускаются знаки "+", "-", "*" и "/" выражение вводится как символьная строка, все числа целые. операция "/" выполняется как целочисленное деление (div). пример: введите выражение: 12*3+45 ответ: 81

Информатика

Ответы

Людмила Анна
num_1 = int(input("Введіть 1 число: "))
diya_1 = input("Введіть дію: ")
num_2 = int(input("Введіть 2 число: "))
diya_2 = input("Введіть дію: ")
num_3 = int(input("Введіть 3 число: "))
if diya_1 == '/':
if diya_2 == '/':
print(num_1,'/',num_2,'/',num_3,'= ', num_1/num_2/num_3)
if diya_2 == '*':
print(num_1,'*',num_2,'/',num_3,'= ', num_1*num_2/num_3)
if diya_2 == '-':
print(num_1,'-',num_2,'/',num_3,'= ', num_1-num_2/num_3)
if diya_2 == '-':
print(num_1,'+',num_2,'/',num_3,'= ', num_1+num_2/num_3)

if diya_1 == '+':
if diya_2 == '*':
print(num_1,'+',num_2,'*',num_3,'= ', num_1+num_2*num_3)
if diya_2 == '/':
print(num_1,'+',num_2,'/',num_3,'= ', num_1+num_2/num_3)
if diya_2 == '+':
print(num_1,'+',num_2,'+',num_3,'= ', num_1+num_2+num_3)
if diya_2 == '-':
print(num_1,'+',num_2,'-',num_3,'= ', num_1+num_2-num_3)

if diya_1 == '*':
if diya_2 == '+':
print(num_1,'*',num_2,'+',num_3,'= ', num_1*num_2+num_3)
if diya_2 == '-':
print(num_1,'*',num_2,'-',num_3,'= ', num_1*num_2-num_3)
if diya_2 == '/':
print(num_1,'*',num_2,'/',num_3,'= ', num_1*num_2/num_3)
if diya_2 == '*':
print(num_1,'*',num_2,'*',num_3,'= ', num_1*num_2*num_3)

if diya_1 == '/':
if diya_2 == '-':
print(num_1,'/',num_2,'/',num_3,'= ', num_1/num_2/num_3)
if diya_2 == '+':
print(num_1,'*',num_2,'+',num_3,'= ', num_1/num_2+num_3)
if diya_2 == '*':
print(num_1,'-',num_2,'*',num_3,'= ', num_1/num_2*num_3)
if diya_2 == '-':
print(num_1,'+',num_2,'-',num_3,'= ', num_1/num_2-num_3)
Giurievna1977
PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!

function NewMatrix(n:integer):array[,] of integer;
begin
  Result:=MatrRandom(n,n,-50,50);
  Result.Println(4); Writeln(4*n*'-')
end;

function KS(a:array[,] of integer):(integer,integer);
begin
  var (k,s,n):=(0,0,a.RowCount-1);
  for var i:=0 to n-1 do
    for var j:=i+1 to n do
      if a[i,j]<0 then (k,s):=(k+1,s+a[i,j]);
  Result:=(k,s)
end;

begin
  var d:=NewMatrix(8);
  var (l,c):=KS(d);
  var t:=NewMatrix(10);
  var (n,a):=KS(t);
  var q:=NewMatrix(7);
  var (m,b):=KS(q);
  Writeln($'l={l}, c={c}, n={n}, a={a}, m={m}, b={b}');
  var (lp,rp):=(c/n+b/l,a/m);
  Writeln($'c/n+b/l={lp}{lp=rp?'' = '':'' <> ''}{rp}');
end.

Пример
 -25  12  43  -8 -15  15 -30  23
   7  49  50   4  38 -37  46  44
  17  21 -37  20  13 -27 -19 -20
   0 -50 -12 -37  23 -33  16 -37
 -43  -6 -35  30  27  11  48  12
   3  15  -8 -25 -38 -47  23  34
 -49  23 -27 -27 -28 -13 -17 -49
 -20  13  42 -16 -24 -43 -50 -10
--------------------------------
 -17  36  -4  -6  48 -34 -33 -44  23   2
 -34  48  32 -45 -32  -3 -22   4 -39 -50
  44  -8  42  20 -39 -36  -1 -36  20  14
 -15  -5  15 -48  43 -24   7 -21  37  36
   5 -33   1  20 -30 -15 -31 -26  -5  -6
 -44  22  46 -50  -4  41  45  26 -17  33
  17 -47 -14 -42 -33  22 -17  30 -37  42
  40  49  18 -24  -5  27  42 -29   0  26
  46 -26  20 -25   7  13  -1  15   6 -48
 -18  31  46 -47 -32   2  31  -8   3  -1
----------------------------------------
 -48 -11 -39   3   5 -43 -46
  20   5  19  50  23 -24   7
  38  -7 -16 -39   2   4 -28
  19 -27 -39   9 -42 -47  15
 -43  43  47  -1  19 -50  24
   6 -38 -34  21   0   9  30
 -41  38 -48   9   5 -12 -35
----------------------------
l=10, c=-275, n=25, a=-654, m=10, b=-369
c/n+b/l=-47.9 <> -65.4

Решить уравнение c/n+b/l=a/m, где l,c – количество и сумма отрицательных элементов матрицы d(8,8) ,
diannaevaaa
Использовать Рисователь
алг Робот
нач
в точку (100,100)
кисть (голубой)
залить (200,500)
линия в точку (300,100)
линия в точку (300,200)
линия в точку (100,200)
линия в точку (100,100)
в точку (70,200)
линия в точку (330,200)
линия в точку (330,430)
линия в точку (70,430)
линия в точку (70,200)
кисть (синий)
залить (200,300)
в точку (70,220)
линия в точку (20, 300)
линия в точку (20,340)
линия в точку (70,260)
в точку (330,230)
линия в точку (380,60)
линия в точку (380,110)
линия в точку (330,260)
прямоугольник (130,130,160,160)
прямоугольник (240,130,270,160)
прямоугольник (160,175,235,190)
прямоугольник (110,430,170,460)
прямоугольник (255,450,310,460)
прямоугольник (255,430,310,460)
кон

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу в питоне напишите программу которая вычисляет выражение, состоящее из трех чисел и двух знаков (допускаются знаки "+", "-", "*" и "/" выражение вводится как символьная строка, все числа целые. операция "/" выполняется как целочисленное деление (div). пример: введите выражение: 12*3+45 ответ: 81
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

qwe54344
Мельникова
Долбоебков_Алексей27
Vrezh
makeeva-nataliya60
Кузнецов
merzlikinairena
utburt
iraira761
Olga_Vyacheslavovich1054
Андреевнатест707
zharovaleks
zakupka-marion
elena-kondyreva
Yurevich1243