Составить программу которая запрашивает длину 2-ух катетов прямоугольного треугольника и выводят гипотенузы. c=a^2+b^2 c: = sqrt(a х а + b х b) продолжите .
program zadan10; var a,b,c:real; begin writeln('vvedite "a"'); readln(a); writeln('vvedite "b"'); readln(b); c:=sqrt(a*a+b*b); writeln('gipatenuza =',c); readln; end.
diannaevaaa
16.04.2023
Program z1; var a,b,c1,c2:real; begin writeln('Введите катет A:'); readln(a); writeln('Введите катет B:'); readln(B); C1:=a*a+b*b; c2:=sqrt(c1); writeln('Гипотенуза в квадрате:',c1); writeln('Корень из гипотенузы:',c2); end.
avto3132
16.04.2023
1. Сообщение о том, что выбран 1 из 4 равновозможных вариантов содержит log2(4) = 2 бита информации (2^2 = 4).
2. Всего символов 150 * 40 * 60 = 360 000. Если считать, что каждый символ кодируется одним байтом, получится 360 000 байт = 351,6 Кбайт (1 Кбайт = 1024 байт)
3. На каждый символ отводится log2(64) = 6 бит, а объём документа 0,75 Кбайт = 0,75 * 1 024 байт = 0,75 * 8 * 1 024 бит = 6 144 бит. Поэтому общее количество символов 6 144 / 6 = 1024. На одну страницу приходится 1024 / 32 = 32 символа.
mrvasilev2012
16.04.2023
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017 // Внимание! Если программа не работает, обновите версию!
function Res(a:integer;op:char;b:integer):integer; begin case op of '+':Result:=a+b; '-':Result:=a-b; '*':Result:=a*b; '/':Result:=a div b end end;
begin var s:=ReadlnString('Вводите:'); var p:=s.Matches('(((\-)?\d+)|[\+\-\*\/])').ToArray; if p.Count<>5 then Writeln('Ошибка!') else begin var op1:=p[1].Value[1]; var op2:=p[3].Value[1]; var a:=p[0].Value.ToInteger; var b:=p[2].Value.ToInteger; var c:=p[4].Value.ToInteger; if (op1 in ['+','-']) and (op2 in ['*','/']) then Writeln('='+Res(Res(b,op2,c),op1,a)) else Writeln('='+Res(Res(a,op1,b),op2,c)) end end.
Это на классическом паскале
program zadan10;
var
a,b,c:real;
begin
writeln('vvedite "a"');
readln(a);
writeln('vvedite "b"');
readln(b);
c:=sqrt(a*a+b*b);
writeln('gipatenuza =',c);
readln;
end.