Tatianamir765654
?>

Написать программу на языке с++(желательно в компиляторе shell c++) заполнить массив случайными числами в интервале [-10; 10] и отобрать в другой массив все четные отрицательные числа. программа 8 класса решите, надо! заранее

Информатика

Ответы

Elen-Fler

package com.company;

import java.util.Arrays;

import java.util.Scanner;

public class Main {

   public static void main(String[] args) {

       Scanner sc = new Scanner(System.in);

       System.out.print("Введите размер массива: ");

       int size = sc.nextInt();

       int[] myArray = new int[size];

       System.out.print("Заполните элементы массива: ");

       for(int i=0; i<size; i++) {

           myArray[i] = sc.nextInt();

       }

       System.out.print("Одинаковые элементы: ");

       for(int i=0; i<myArray.length; i++) {

           for (int j=i+1; j<myArray.length; j++) {

               if(myArray[i] == myArray[j]) {

                   System.out.println(j);

               }

           }

       }

   }

}

Объяснение:

Я использую язык программирования java, думаю переписать на нужный вам вы сможете.

abcd138191
26 заглавных букв + 26 строчных букв + 10 цифр + 6 символов = 68 знаков используются в паролях.

Один такой знак занимает минимально 7 бит (2^6=64 < 68 < 128=2^7). 
Но символы кодируют целым числом байт. значит по 1 байту (8 бит) на символ. Длина пароля равна 12 символов, которые занимают 12 байт.

Всего выделено 1080 байт на 40 пользователей, то есть 1080/40 = 27 байт на одного пользователя.

Из них 12 байт занято под пароль. Остается 27-12=15 байт можно использовать для хранения дополнительных сведений о каждом пользователе

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на языке с++(желательно в компиляторе shell c++) заполнить массив случайными числами в интервале [-10; 10] и отобрать в другой массив все четные отрицательные числа. программа 8 класса решите, надо! заранее
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Марина_Мария
Сергей_Комарова899
iburejko7
Николаевич1033
Александр
Svatela37
Никитина580
tokarevmax
ielienakozlova696
julya847
zaretskaya37
inulikb
atenza3736
fastprofit
tetralek