Задача 1:
const N = 15;
const MAX = 15;
const MIN = -15;
var A: array [1..N] of integer;
var i,s1,s2: integer;
begin
randomize();
s1:=0;
s2:=0;
writeln('Исходный массив: ');
for i:=1 to N do
begin
A[i]:=random(MAX-MIN+1)+MIN;
write(A[i],' ');
if (A[i]<0) then s1:=s1+A[i];
if (A[i] mod 3 = 0) then s2:=s2+A[i];
end;
writeln();
writeln('Сумма всех отрицательных элементов: ',s1);
writeln('Сумма всех элементов, кратных 3: ',s2);
end.
Задача 2:
const N = 20;
const MAX = 33;
const MIN = -15;
var A: array [1..N] of integer;
var i,imax,imin: integer;
begin
randomize();
imin:=1;
imax:=1;
writeln('Исходный массив: ');
for i:=1 to N do
begin
A[i]:=random(MAX-MIN+1)+MIN;
write(A[i],' ');
if (A[i]<A[imin]) then imin:=i;
if (A[i]>A[imax]) then imax:=i;
end;
writeln();
writeln('Номер минимального элемента массива: ',imin);
writeln('Номер максимального элемента массива: ',imax);
end.
Поделитесь своими знаниями, ответьте на вопрос:
Напишите программу, которая получает с клавиатуры натуральное число и определяет, простое оно или нет. для этого нужно делить число на все натуральные числа, начиная с 2, пока не получится деление без остатка. паскаль
begin
readln(num);
for i:=2 to num do
if num mod i = 0 then break;
if i = num then writeln('число простое')
else writeln('число составное');
end.