shchepinasm
?>

Составьте блок-схему алгоритма и программу вычисления произведения четных чисел, меньших 15. составьте таблицу значений функции у = 5х -2 на отрезке [1; 20] с шагом b=2. составьте программу вычисления суммы 80 первых членов арифметической прогрессии, если a1 = 10; d= 3.

Информатика

Ответы

bagramyansvetlana
Это алгебра или информатика
Хохлова Иванович
// PascalABC.NET 3.1, сборка 1172 от 19.02.2016
begin
  var s:=Range(1,ReadInteger('n='),2).Select(x->Rec(x,x*x,x*x*x));
  foreach var e in s do
    Writeln(e.Item1:10,e.Item2:10,e.Item3:10)
end.

Тестовое решение:
n= 20
         1         1         1
         3         9        27
         5        25       125
         7        49       343
         9        81       729
        11       121      1331
        13       169      2197
        15       225      3375
        17       289      4913
        19       361      6859
avto3132

112 секунд

Объяснение:

V = t * f * i * k, где  

V - информационный объём аудио файла (размер файла, содержащего запись звука)

t - общая длительность звучания (секунды)

f - частота дискретизации (Гц, количество значений амплитуды звука, фиксируемых за одну секунду)

i - глубина звука (разрешение) (число бит, используемых для хранения каждого измеренного значения)

k -  количество каналов записи (1 - моно, 2 - стерео и т.д.)

Дано:

V = 14 000 Кбайт = 14 000 * 1 024 = 14 336 000 байт = 14 336 000 * 8 = 114 688 000 бит

f = 64 000 Гц

i = 16 бит

k = 1

Найти:

t

V = t * f * i * k

t=\frac{V}{f * i * k}

t = \frac{114688000}{64 000 * 16 * 1} =\frac{114688000}{1024000} =112 секунд

t = 112 секунд = 1 мин 52 секунды

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте блок-схему алгоритма и программу вычисления произведения четных чисел, меньших 15. составьте таблицу значений функции у = 5х -2 на отрезке [1; 20] с шагом b=2. составьте программу вычисления суммы 80 первых членов арифметической прогрессии, если a1 = 10; d= 3.
Ваше имя (никнейм)*
Email*
Комментарий*