Nadezhdachizhikova7968
?>

Пусть в массиве т (30) записана температура воздуха за ноябрь. составить программу, которая выведет на экран день, когда была самая а) низкая температура. б) высокая температура.

Информатика

Ответы

ak74-81
#Python
print(t.index(max(t)))#Самая высокая
print(t.index(min(t)))#Самая низкая

Переходите на питон)
m79857860146895
1. С=2*Pi*R, S= Pi*R^2, V=4/3*Pi*R^3, где Pi=3,14, заданный радиус R
2. P=a+b, S=1/2*a*b, где a и b - данные катеты
3. Пусть даны координаты трех вершин треугольника A(x1;y1), B(x2;y2), C(x3;y3).
Расстояние между двумя точками вычисляется по формуле
d= \sqrt{ ( x_{2} - x_{1} )^{2}+ ( y_{2} - y_{1} )^{2} }
Тогда периметр треугольника можно вычислить по формуле:
P=sqrt((x2-x1)^2+(y2-y1)^2)+sqrt((x3-x2)^2+(y3-y2)^2)+sqrt((x3-x1)^2+(y3-y1)^2).
Площадь треугольника по формуле Герона вычисляется по формуле:
s= \sqrt{p(p-a)(p-b)(p-c)}, где p= \frac{a+b+c}{2}-полу периметр треугольника.
S=sqrt((sqrt((x2-x1)^2+(y2-y1)^2)+sqrt((x3-x2)^2+(y3-y2)^2)+sqrt((x3-x1)^2+(y3-y1)^2)/2*(sqrt((x2-x1)^2+(y2-y1)^2)+sqrt((x3-x2)^2+(y3-y2)^2)+sqrt((x3-x1)^2+(y3-y1)^2)/2-sqrt((x2-x1)^2+(y2-y1)^2))*(sqrt((x2-x1)^2+(y2-y1)^2)+sqrt((x3-x2)^2+(y3-y2)^2)+sqrt((x3-x1)^2+(y3-y1)^2)/2-+sqrt((x3-x2)^2+(y3-y2)^2))*(sqrt((x2-x1)^2+(y2-y1)^2)+sqrt((x3-x2)^2+(y3-y2)^2)+sqrt((x3-x1)^2+(y3-y1)^2)/2-sqrt((x3-x1)^2+(y3-y1)^2))
4. Среднее геометрическое трех чисел вычисляется по формуле
\sqrt[3]{abc} или
(a*b*c)^1/3
Станислав Валерий1696
//Pascal ABC.NET v3.1 сборка 1219

Const
 n=10;

 Var
 ar:array[1..n] of integer;
 k,i,c:integer;
begin
 randomize;
 writeln('First array:');
 for i:=1 to n do
  begin
   ar[i]:=random(9);
   write(ar[i]:4);
  end;
 writeln;
 write('Enter index:');
readln(k);
 if (k=1) or (n=1) then
   begin
   writeln('Mwahahahaha(no)');
   exit;
  end;
 c:=ar[k+1];
 ar[k+1]:=ar[k-1];
 ar[k-1]:=c;
 writeln('Final array:');
 for i:=1 to n do
  write(ar[i]:4);
end.

Пример работы программы:
First array:
   1   8   4   2   8   5   8   7   1   8
Enter index:3
Final array:
   1   2   4   8   8   5   8   7   1   8

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Пусть в массиве т (30) записана температура воздуха за ноябрь. составить программу, которая выведет на экран день, когда была самая а) низкая температура. б) высокая температура.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

maxkuskov2485
zhmulyov-denis8
Reginahappy
jstepanova
Вадим-Рашад323
izykova22
Александра-Андрей909
sokolskiy458
bb495
Екатерина
Natalya1070
natalyaionova
beaevgen711
Nikolaevna382
mpityk