Дано натуральное число n (где n больше или равно нулю вычислить: z=2*5**(3n-1). нужно написать программу в паскале вида program-var-begin-writeln-write-read-end и т.д. и т.п.
begin Write('n='); ReadLn(n); if n = 0 then WriteLn('z=-1') else if (n < 0) then WriteLn('Введено отрицательное число') else begin z := 1; for i := 1 to n do z := z * 1 * (3 * i - 1); WriteLn('z=', z); end; end.
rodin4010
31.05.2020
// PascalABC.NET 3.1, сборка 1250 от 28.05.2016 begin var a:array[1..3] of string; var l:array[1..3] of integer; for var i:=1 to 3 do begin Write('Город ',i,': '); Readln(a[i]); l[i]:=Length(a[i]) end; var imin:=1; var imax:=1; for var i:=2 to 3 do begin if l[i]<l[imin] then imin:=i; if l[i]>l[imax] then imax:=i end; Writeln('Самое длинное название- ',a[imax]); Writeln('Самое короткое название- ',a[imin]) end.
Тестовое решение Город 1: Москва Город 2: Минск Город 3: Киев Самое длинное название- Москва Самое короткое название- Киев
Gaziev1636
31.05.2020
// PascalABC.NET 3.1, сборка 1250 от 28.05.2016 begin var a:array[1..3] of string; var l:array[1..3] of integer; for var i:=1 to 3 do begin Write('Город ',i,': '); Readln(a[i]); l[i]:=Length(a[i]) end; var imin:=1; var imax:=1; for var i:=2 to 3 do begin if l[i]<l[imin] then imin:=i; if l[i]>l[imax] then imax:=i end; Writeln('Самое длинное название- ',a[imax]); Writeln('Самое короткое название- ',a[imin]) end.
Тестовое решение Город 1: Москва Город 2: Минск Город 3: Киев Самое длинное название- Москва Самое короткое название- Киев
n, i, z: Integer;
begin
Write('n=');
ReadLn(n);
if n = 0 then
WriteLn('z=-1')
else if (n < 0) then
WriteLn('Введено отрицательное число')
else
begin
z := 1;
for i := 1 to n do
z := z * 1 * (3 * i - 1);
WriteLn('z=', z);
end;
end.