studiojanara
?>

Нужна ! во входном файле две строки. в первой строке содержится одно число n. во второй строке - n целых чисел, разделенных пробелами. напишите программу, которая выведет в выходной файл одно число - разность минимального и максимального чисел из второй строки входного файла.

Информатика

Ответы

Nikolaevich_Vladimirovich1509
Program aaa;
var
   n,i,a,max,min:integer;
begin
   readln(n);
   for i:=1 to n do begin
      read(a);
      if(i=1) then begin
         max:=a;
         min:=a;
      end;
      if(a>max) then max:=a;
      if(a<min) then min:=a;
   end;
   writeln(min-max);
end.
Andreevich

К блоку Старт добавь блок цикл.

К блоку цикл добавь блок переключатель.

Для получения данных с датчика установи режим:

Датчик цвета-Измерение-Цвет.

В верхней части блока Переключатель добавь блок рулевое управление,установи режим включить.Измени состояние блока Рулевое управление на 50. Измени цвет на черный.

Не забудь изменить цвет в нижней части блока Переключатель с ,,Нет цвета'' на белый. Добавь блок Рулевое управление, установи режим Включить.Измени состояние блока Рулевое управление на (-50).

Загрузи программу на робота.

Объяснение:

Вроде так

Щербаков33
Var m : array[0..6] of Integer;
  i,k,N : Integer;
Begin
  For i:=0 to 6 do m[i]:=0;
  Readln(N);
  k:=6;
  While N>0 do
  Begin
    If N>=Power(2,k) then
    Begin
      N:=N-Trunc(Power(2,k));
      Inc(m[k]);
    end else Dec(k);
  end;
  For i:=0 to 6 do Writeln(Power(2,i),'  ',m[i],' шт.');
end.

Еще вариант:
Const
  NN = 7;
  money : array[1..7] of Integer = (1,2,4,8,16,32,64);
Var m : array[1..NN] of Integer;
  i,k,N : Integer;
Begin
  For i:=1 to NN do m[i]:=0;
  Readln(N);
  k:=NN;
  While N>0 do
  Begin
    If N>=money[k] then
    Begin
      N:=N-money[k];
      Inc(m[k]);
    end else Dec(k);
  end;
  For i:=1 to NN do Writeln(money[i],'  ',m[i],' шт.');
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужна ! во входном файле две строки. в первой строке содержится одно число n. во второй строке - n целых чисел, разделенных пробелами. напишите программу, которая выведет в выходной файл одно число - разность минимального и максимального чисел из второй строки входного файла.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Орлова
Maksim Dmitrii1579
T91610933073266
garunkhachatryan
yelenaSmiryagin
Голосова-Лобанов1555
doorhan42n6868
arturusinsk5
mariia39
Baidina
Виктория-Марина626
merx80
strager338
tyrenumberone
kate1610