zanthia94
?>

Составьте программу получения из слова "дисковод" слова "воск", используя операцию сцепления и функцию copy

Информатика

Ответы

Павел_Перелыгин
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var s:='дисковод';
  Writeln(Copy(s,6,2)+Copy(s,3,2))
end.
ivnivas2008

Объяснение:

1) 6 бит

2)По формуле N=2^i найдем, сколько было круглых фигурок - 2^2 = 4; Всего фигурок было 15+4=19. ответ: 19

3) я не знаю

4)Обозначим количество красных кубиков через x, тогда желтых будет 2x, а зеленых (2x + 6). Всего кубиков (5x + 6). Раз желтый кубик дает 2 бита, по формуле Шеннона желтые кубики составляют долю 2 в (-2) степени, т. е. 1/4 от всех кубиков. Значит всего кубиков 8x. Приравниваем 5x + 6 = 8x. Отсюда x = 2, т. е. зеленых кубиков 2x + 6 = 10.  

Итак, всего 10 зеленых кубиков.

Paradismebel

Объяснение:

1) 6 бит

2)По формуле N=2^i найдем, сколько было круглых фигурок - 2^2 = 4; Всего фигурок было 15+4=19. ответ: 19

3) я не знаю

4)Обозначим количество красных кубиков через x, тогда желтых будет 2x, а зеленых (2x + 6). Всего кубиков (5x + 6). Раз желтый кубик дает 2 бита, по формуле Шеннона желтые кубики составляют долю 2 в (-2) степени, т. е. 1/4 от всех кубиков. Значит всего кубиков 8x. Приравниваем 5x + 6 = 8x. Отсюда x = 2, т. е. зеленых кубиков 2x + 6 = 10.  

Итак, всего 10 зеленых кубиков.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу получения из слова "дисковод" слова "воск", используя операцию сцепления и функцию copy
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

mospaskrasnogorbukh
arturnanda803
Бурмистров_Салагин1074
Avdeeva Yelizaveta
gallush9
Arsen-araqelyan20164
dakimov
sergeychelyshev197618
васильевич
Tatyana-Sergeevna108
buleckovd8724
ПетросовичЗаславский
Иванова
razumeiko0790
Alekseevich_Viktorovna