tarja4140
?>

Составить программу которая определяет наличие одинаковых цифр в произвольном 3-значном числе

Информатика

Ответы

aggeeva
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var n:=Abs(ReadInteger('Введите целое трехзначное число'));
  if n.Between(100,999) then
    if n.ToString.Select(c->c).Distinct.Count<3 then
      Writeln('Есть одинаковые цифры')
    else Writeln('Нет одинаковых цифр')
  else Writeln('Число должно быть трехзначным')
end.
phmad7
Var a,a1,a2,a3:integer;
begin
readln(a);
a1:=a div 100;
a2:=a div 10 mod 10;
a3:=a mod 10;
if (a1=a2)or(a1=a3)or(a2=a3)
then writeln('Одинаковые цифры есть')
else writeln('Одинаковых цифр нет');
end.

Пример:
121
Одинаковые цифры есть
Кирилл_Гульницкий
В качестве примера равномерного кода можно назвать ASCII-таблицу, где каждому из 256 символов сопоставлено двоичное значение от 00000000 до 11111111. Независимо от вероятности появления символа на его представление отводится 1 байт, или 8 бит. Как известно, национальные языки обладают большой избыточностью, то есть разницей между энтропией источника и максимально возможной энтропией, обусловленной равной вероятностью появления любого символа из алфавита. Например, избыточность русского языка составляет 70%, а английского – 50%. Это в частности означает, что некоторые буквы появляются в тексте гораздо чаще других и поэтому использовать равномерное кодирование нерационально.
При неравномерном кодировании часто встречающимся символам сопоставляются более короткие кодовые последовательности, редко встречающимся – более длинные. За счет этого удается значительно сократить объем файла без потерь информации. Существует несколько методов неравномерного кодирования, важнейших из которых является метод Шеннона-Фано.
как-то так 
vipteatr
//где-то не закрыла begin end
var A:array [1..40] of integer;
sa,s3,s10,k,i: integer;
begin
sa:=0;
s10:=0;
s3:=0;
k:=0;
writeln('исходные значения');
for i:=1 to 40 do
begin
 A[i]:= random(21);
write(A[i],'')
end;
writeln;
for i:=1 to 40 do
 begin
 if A[i]mod 2<>0 then
begin
 sa:=sa+A[i];
k:=k+1;
if A[i]<10 then s10:=s10+A[i];
if A[i] mod 3=0 then
s3:=s3+A[i];                                     //здесь было странное выражение   
end;
end;                                                  //здесь
writeln('среднее арефмитическое нечетных чисел',sa/k:5:0);
writeln('сумма чисел, не превышающих', s10);
writeln('сумма чисел, кратных трем', s3);
End.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу которая определяет наличие одинаковых цифр в произвольном 3-значном числе
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

lavorenn
nikv568734
aivia29
om805633748
misspodvigina
madjk
alexsan-0837
родичева1812
zinasekina4
evsmorodina
yyyaga
Филиппович_Николаевич
motor2218
Pirogovskii695
annashersheva