Viktor1316
?>

Сравнение дробей напишите программу, позволяющую сравнить две обыкновенные дроби. ввод на ввод подается четыре целых положительных числа (все числа не превышают 10 4 ): в первой строке числитель и знаменатель первой дроби, во второй строке числитель и знаменатель второй дроби. вывод если первая дробь меньше второй, выведите ‘< ’, если дроби равны, выведите ‘=’, если первая дробь больше второй, выведите ‘> ’. ввод вывод 1 2 3 4 < 17 34 1 2 = решить на паскаль

Информатика

Ответы

Николаевна1564
PascalABC.NET 3.3.5, сборка 1669 от 21.05.2018
Внимание! Если программа не работает, обновите версию!

begin
  var (a,b):=ReadlnInteger2; var (c,d):=ReadlnInteger2;
  var k:=Sign(a*d-b*c);
  Writeln(k>0 ? '>' : k=0 ? '=' : '<')
end.

Сравнение дробей напишите программу, позволяющую сравнить две обыкновенные дроби. ввод на ввод подае
Lenok33lenok89

Алгоритм - система последовательных операций.

Конечность алгоритма - означает расчлененность определяемого алгоритмом вычислительного процесса на отдельные этапы, возможность выполнения которых исполнителем (компьютером) не вызывает сомнений; конечность.

Понятность алгоритма - означает, что алгоритм должен содержать только те команды, которые входят в набор команд, который может выполнить конкретный исполнитель.

Точность алгоритма - детерминированность (определенность, точность, однозначность) . Это свойство заключается в том, что при задании одних и тех же исходных данных несколько раз алгоритм будет выполняться абсолютно одинаково и всегда будет получен один и тот же результат.

ТигранКалмыкова
#include <iostream>

using namespace std;

int gcd(int a, int b);

int main()
{
    freopen("input.txt", "r", stdin);
    freopen("output.txt", "w", stdout);
   
    int n;
   
    cin >> n;
   
    for (int i = 0; i < n; ++i)
    {
        int a, b, c, d;
       
        scanf("%d/%d+%d/%d=", &a, &b, &c, &d);
       
        int num = a * d + b * c;
        int den = b * d;
       
        int cur_gcd = gcd(num, den);
       
        num /= cur_gcd;
        den /= cur_gcd;
       
        cout << num;
        if(den != 1)
            cout << '/' << den;
        cout << endl;
    }
   
    fclose(stdin);
    fclose(stdout);
    return 0;
}

int gcd(int a, int b)
{
    if(a == 0)
        return b;
    return gcd(b % a, a);
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Сравнение дробей напишите программу, позволяющую сравнить две обыкновенные дроби. ввод на ввод подается четыре целых положительных числа (все числа не превышают 10 4 ): в первой строке числитель и знаменатель первой дроби, во второй строке числитель и знаменатель второй дроби. вывод если первая дробь меньше второй, выведите ‘< ’, если дроби равны, выведите ‘=’, если первая дробь больше второй, выведите ‘> ’. ввод вывод 1 2 3 4 < 17 34 1 2 = решить на паскаль
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

stmr29
dawlatowajana
multikbo3049
pristav9
Эрендженова
koochma
Алина1564
borzhemskaya19823110
Кириллов57
docvet4
Pilotmi247074
anovikovsr
anton
stasletter
Alena824