bagrjashv41
?>

Дана строка не более 50 символов. переписать в обратном порядке все слова, начинающиеся с заданной буквы. определить количество предложений в строке. написать программу в паскале

Информатика

Ответы

vera-spicina
PascalABC.NET 3.4.0, сборка 1675 от 12.06.2018
Внимание! Если программа не работает, обновите версию!

begin
  var adelim:=' .,;:!?-'.ToCharArray;
  var s:=ReadlnString;
  Writeln(25*'- ');
  var c:=ReadlnChar('Буква для поиска слов:'); Writeln(25*'- ');
  var ww:=s.ToWords(adelim).Where(w->w.First=c);
  foreach var w in ww do begin
    var i:=Pos(w,s);
    Delete(s,i,w.Length); Insert(w.Inverse,s,i)
    end;
  s.Println; Writeln(25*'- ');
  Writeln('Предложений всего: ',s.ToWords('.').Count)
end.

Дана строка не более 50 символов. переписать в обратном порядке все слова, начинающиеся с заданной б
raa-0485428
// PascalABC.NET 
// Версия 3.3.5 сборка 1662 (29.04.2018)

begin
  var b := ReadlnString('Введите строку -').ToLower+' '; 
  var (z,r) := (',!?.:;'.ToCharArray,'!.?;'.ToCharArray);
  var tt:=true; Range(1,b.Length+b.ToCharArray.Where(t->t in z).Count).ForEach(t->if (b[t] in z) and tt then begin Insert(' ', b, t); tt:=false end else tt:=true);
  var a := b.ToWords;
  var x := ReadlnChar('Буква -');
  var (w, i) := a.Select((w, i)-> (w, i)).Where(t -> t[0].ToString.First.ToLower = x).Reverse.UnZipTuple; 
  i := i.Reverse;
  foreach var t in w.Zip(i, (p, q)-> (p, q)) do a[t[1]] := t[0];
  b := string.Join(' ', a);
  tt:=true; Range(1,b.Length-b.ToCharArray.Where(t->t in z).Count+1).ForEach(t->if (b[t] in z) and tt then begin Delete(b, t - 1, 1); tt:=false end else tt:=true); 
  b.Println; Println('Количество предложений:',b.ToWords(r).Count);
end.

Пример в приложении.

Дана строка не более 50 символов. переписать в обратном порядке все слова, начинающиеся с заданной б
dm1trviktor585

Задание 1

program HelloMoney;

 var

 y, i: integer; // Объявим переменные для количества лет вклада и для счетчика цикла  

p, s: real; //Объявим переменные для количества процентов и величины вклада

begin

write('Какая сумма вклада? ');

readln(s); // Указываем сколько составляет вклад

write('На сколько лет вклад? ');

readln(y); // Указываем на сколько лет вклад

write('Какая процентная ставка?');

readln(p); // Указываем процентную ставку

for i:=1 to y do

s := s + s*p/100; // Прибавляем к вкладу ежегодный процент

write('Сумма денег составит: ', s);

end.

Объяснение:

akopovarch
Пусть а - число правильных ответов, с - число неправильных ответов. тогда число вопросов, на которые ответы даны не были - 25-а-с 5*а-9*с=40 с у нас больше либо равно 1, тогда делаем методом подстановки, не забывая, что а - обязательно целое число. с=1 5а-9=40, 5а=49, а - число не целое, значит, не подходит. с=2 5а-18=40, 5а=58, а - число не целое, значит, не подходит. с=3 5а-27=40, 5а=67, а - число не целое, значит, не подходит. с=4 5а-36=40, 5а=76, а - число не целое, значит, не подходит. с=5 5а-45=40, 5а=85, откуда а =17. ответ: 17.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дана строка не более 50 символов. переписать в обратном порядке все слова, начинающиеся с заданной буквы. определить количество предложений в строке. написать программу в паскале
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

zrs-546
nikitavertiev98400
npprang21
гайсанов
zbellatriks
Ushakova Sakhno
alekseev13602
zatoichi69
vallod
alexeytikhonov
dkedrin74038
jim2k
Дмитрий192
Вячеславович-Дмитрий1694
elenak26038778