npdialog66
?>

Составить программу, которая будет считывать введённое четырехзначное число. каждую цифру этого числа необходимо вывести в новой строке

Информатика

Ответы

Aleksandrovich1415
// PascalABC.NET

begin
   var num: integer;
   while true do
   begin
      num := ReadlnInteger('введите 4-х значное число, num =');
      if (num > 999) and (num <= 9999)
         then break;
   end;
   
   var str := num.ToString;
   
   foreach var x in str do
      Println(x)
end.
ВостриковаСтародубцева1980
Var a,f:integer;
begin
write('Введите четырехзначное число: ');
readln(a);
f:=a div 1000;
writeln(f);
a:=a-1000*f;
f:=a div 100;
writeln(f);
a:=a-100*f;
f:=a div 10;
writeln(f);
a:=a-10*f;
writeln(a);
end.
natalia595977

begin

 var size := readinteger;

 var arr := ArrRandomInteger(size, -100, 100);

 arr.Println;

 var quantity := 0;

 for var i := 0 to arr.Length - 1 do

 begin

   if (arr[i] > 25) and (arr[i] < 99) and (arr[i] mod 2 <> 0) then

   begin

     inc(quantity);

   end;

 end;

 write(quantity);

end.

Объяснение:

begin  // Начало программы

 var size := readinteger;   // Переменная, хранящая размер массива, считывается с клавиатуры

 var arr := ArrRandomInteger(size, -100, 100);  // Объявление массива размером size + заполнение массива случайными значениями из диапазона [-100, 100].

 arr.Println;  // Вывод массива

 var quantity := 0;  // Переменная, хранящая количество элементов, равна 0

 for var i := 0 to arr.Length - 1 do  // Идём от нуля до размера массива - 1

 begin  // Начало цикла

   if (arr[i] > 25) and (arr[i] < 99) and (arr[i] mod 2 <> 0) then  // Если значение массива с индексом i > 25 И < 99 И нечетное, тогда

  begin  // Начало условного оператора

   begin  // Начало условного оператора

     inc(quantity);  // Увеличиваем значение переменной quantity на единицу

   end;  // Конец условного оператора

 end;  // Конец цикла

 write(quantity);  // Выводим ответ

end. // Конец программы

info6

0

Объяснение:

Функция имеет два базовых случая. В первом случае если параметр функции - нечетное число, то возвращается ответ "No", во втором случае если параметр функции равен 2, то возвращается ответ "Yes". Для всех других значений параметра происходит его целочисленное уменьшение в два раза. Таким образом, в приведенном программном коде определяется, является ли число n степенью 2.

Так как первоначальное значение n=21, то сразу наступает условие для базового случая 21%2==1. Поэтому рекурсивные вызовы отсутствуют, следовательно, глубина рекурсии равна 0.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, которая будет считывать введённое четырехзначное число. каждую цифру этого числа необходимо вывести в новой строке
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Егорова
Виталий887
plv-57
Olgax732
buriginast5
nopel91668
Решетникова
Maria095096
vera-spicina
Павловна897
D-posilochka
horst58
Yuliya Aleksandr282
Olegmgu11986
steam22-9940