Yuliya Aleksandr686
?>

1)автомобильный номер длиной 5 символов составляют из заглавных букв(задействовано 30 различных букв) и любых десятичных цифр в любом порядке. каждый такой номер в компьютерной программе записывается минимально возможным и одинаково целым количеством байт(при этом используют посимвольное кодирование и все символы кодируются одинаковым и минимально возможным количеством бит определите объём памяти, отводимый этой программой для записи 50 номеров. 2)при регистрации в системе каждому пользователю выдаётся пароль, состоящий из 11 символов и содержащий только символы и, к, л, м, н. каждый такой пароль в компьютерной программе записывается минимально возможным и одинаковым количеством байт(при этом используют посимвольное кодирование и все символы кодируются одинаковым и минимально возможным количеством бит). определите объём памяти, отводимый этой программой для записи 20 паролей. 3)при регистрации в системе каждому пользователю выдаётся пароль, состоящий из 15 символов и содержащий только символы к, о, м, п, ь, ю, т, е, р. каждый такой пароль записывается минимально возможным и одинаково целым количеством байт. определите объём памяти, отводимый этой программой для записи 30 паролей.

Информатика

Ответы

Валерьевна1601
Const
  n=10;
var
  a,b,c:array[1..n] of real;
  i:integer;
begin
  Writeln('Введите элементы массива');
  for i:=1 to n do Read(a[i]);
  Writeln('   A      B      C');
  for i:=1 to n do
  begin
    b[i]:=a[n-i+1]; c[i]:=(a[i]+b[i])/2;
    Writeln(a[i]:7:3,b[i]:7:3,c[i]:7:3)
  end
end.

Тестовое решение:
Введите элементы массива
1.26 -0.3 6.18 7 -7.04 -9.9 -1.7 -2.955 1.75 0.245
   A      B      C
  1.260  0.245  0.753
 -0.300  1.750  0.725
  6.180 -2.955  1.613
  7.000 -1.700  2.650
 -7.040 -9.900 -8.470
 -9.900 -7.040 -8.470
 -1.700  7.000  2.650
 -2.955  6.180  1.613
  1.750 -0.300  0.725
  0.245  1.260  0.753

Блок-схема во вложении

Нарисовать блок схему алгоритма и написать программу,которая: 1)вводит массив а из 10 чисел 2)заполн
ИгоревичАндрей
Const
  n=40;
var
  a:array[1..n] of integer;
  i,amax,n1,nn:integer;
begin
  Randomize;
  Writeln('Элементы массива');
  amax:=0;
  for i := 1 to n do
  begin
    a[i]:=Random(61)+170; { [170..230] }
    Write(a[i]:4);
    if amax<a[i] then
      begin amax:=a[i]; n1:=i; nn:=i end
    else
      begin if amax=a[i] then nn:=i end
  end;
  Writeln;
  Writeln('Номер первого автомобиля ',n1,', последнего- ',nn)
end.

Тестовое решение:
Элементы массива
 185 202 226 209 200 183 219 181 228 181 206 171 182 210 226 187 214 229 219 219 219 206 229 183 178 177 197 199 180 186 183 203 191 194 214 197 215 194 221 187
Номер первого автомобиля 18, последнего- 23

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1)автомобильный номер длиной 5 символов составляют из заглавных букв(задействовано 30 различных букв) и любых десятичных цифр в любом порядке. каждый такой номер в компьютерной программе записывается минимально возможным и одинаково целым количеством байт(при этом используют посимвольное кодирование и все символы кодируются одинаковым и минимально возможным количеством бит определите объём памяти, отводимый этой программой для записи 50 номеров. 2)при регистрации в системе каждому пользователю выдаётся пароль, состоящий из 11 символов и содержащий только символы и, к, л, м, н. каждый такой пароль в компьютерной программе записывается минимально возможным и одинаковым количеством байт(при этом используют посимвольное кодирование и все символы кодируются одинаковым и минимально возможным количеством бит). определите объём памяти, отводимый этой программой для записи 20 паролей. 3)при регистрации в системе каждому пользователю выдаётся пароль, состоящий из 15 символов и содержащий только символы к, о, м, п, ь, ю, т, е, р. каждый такой пароль записывается минимально возможным и одинаково целым количеством байт. определите объём памяти, отводимый этой программой для записи 30 паролей.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

zakaz1
VSpivak3122
КутузоваМартенюк
simonovaliubov5852
sakh2010kprf7
bulin2001
Amelin-Alipova
Vasilevich Fokin
ooofishai4064
natura-domA90
re-art
Azat859
hrim5736
chavagorin
angelina-uj1350