samoilovcoc
?>

Составить программу, выводящую значение true или false. шахматный король за один ход может переместиться с одного заданного поля на другое (каждое после задано двумя координатами - целыми числами от 1 до 8 на паскале

Информатика

Ответы

elenaneretina

Program KING;

Var x,y,x1,y1: integer;

Begin

writeln('Введите координаты расположения Короля:');

write('Коор. x - '); readln(x);

write('Коор. y - '); readln(y);

writeln('Введите координаты клетки хода:');

write('Коор. x - '); readln(x1);

write('Коор. y - '); readln(y1);

if ((x = x1) and (y = y1))

then writeln('FALSE')

else if (abs(x1 - x) < 2)

then if (abs(y1 - y) < 2)

then writeln('TRUE')

else writeln('FALSE')

else writeln('FALSE');

End.

arbat
Const   n = 5; var   i: integer;   a: array[1..n * 2 + 1] of integer; begin   writeln('исходный массив: ');   for i : = 1 to 2 * n do   begin       a[i] : = random(99) + 1;       write(a[i] : 5);   end;   for i : = 2 * n + 1 downto n + 1 do       a[i] : = a[i - 1];   a[n + 1] : = 0;   writeln();   writeln('полученный массив: ');   for i : = 1 to 2 * n + 1 do       write(a[i] : 5); end.
sastakhova
(18 чисел)                                                                                                                     101,102,103,120,130,123,132,201,203,230,213,210,301,302,320,312,321,310.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, выводящую значение true или false. шахматный король за один ход может переместиться с одного заданного поля на другое (каждое после задано двумя координатами - целыми числами от 1 до 8 на паскале
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ag-modul
Pogosyan Nataliya
shumeikoElena362
Андреевич-Екатерина1974
svetrusval
tenvalerij
jeep75
Ruzalina_Svetlana1435
JisesLove19955
AlekseiMardanova
zrs-546
Konchenko1980
Oksana-Kirakosyan1301
Dimston134877
maxchemaxim14