vypolga1347
?>

Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры)

Информатика

Ответы

tanya14757702

Найти среднее арифметическое всех целых чисел от 1 до 1000.

3.Пользователь вводит две границы диапазона, вывести на экран все числа из этого диапазона. Предусмотреть, чтобы пользователь мог вводить границы диапазона в произвольном порядке.

вывести все четные числа из диапазона.

вывести все нечетные числа из диапазона.

вывести все числа, кратные семи

4.Пользователь с клавиатуры вводит числа. Посчитать их сумму и вывести на экран, как только пользователь введет ноль.

Екатерина_Кирушев

1)это процесс передачи информации о состоянии объекта объекту.

2) алгоритм в системе без обратной связи имеет линейную (последовательную) структуру.

3)при наличии обратной связи алгоритм может быть более гибким, допускающим проверку условий, ветвления и циклы

4)системы, в которых роль объекта поручается компьютеру, называются автоматическими системами с программным .

5) объект - учитель, а ученики являются объектом . прямой канал передачи информации - передача знаний учителем, а обратная связь - ответы учеников, результаты контрольных работ, сочинения и т. п. учителю обратная связь дает информацию о достижении поставленных им целей - когда ученики выполнили .  

6)цикл: учитель выставляет оценки в журнал; ветвление: если иванов , то учитель его выгоняет, если нет(иначе) оставляет в классе.

7)модель с обратной связью

8)информативная доска с голосовой подачей информации. используется видео микрофон с распознованием ученика.(можно сделать для каждого ученика отдельную клавиатуру с которой он будет вводить вопрос,тем самым повышая мобильность системы)

из плюсов: мобильность,скорость работы простое .

из минусов: индивидуальность,стандартное мышление

puchkovajulia

function Len(x1,y1, x2, y2:real):real;

begin

   Len := sqrt( sqr(x1 - x2) + sqr(y1 - y2) );

end;

 

var

  x1,x2,x3,x4,x5, y1, y2, y3, y4, y5:real;

begin

   write('x1 = '); readln(x1);

   write('y1 = '); readln(y1);

   write('x2 = '); readln(x2);

   write('y2 = '); readln(y2);

   write('x3 = '); readln(x3);

   write('y3 = '); readln(y3);

   write('x4 = '); readln(x4);

   write('y4 = '); readln(y4);

   write('x5 = '); readln(x5);

   write('y5 = '); readln(y5);

   writeln('P = ', Len(x1,y1,x2,y2) + Len(x2,y2,x3,y3) + Len(x3,y3,x4,y4) + Len(x4,y4,x5,y5) + Len(x5,y5,x1,y1));

end.

 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

dksvetlydir
Takhmina-Komarova1415
Mariya694
osirparts7854
artemka56rus
priemni451
nkochladze
zabrodin
re-art
dimaproh
Алексей Ксения
ribanina
Volkovapavel
Alyona744
ВалентиновичСуриковна1104
Aнaлитикaлық мaшинaAнaлитикaлық мaшинa