perfectorg
?>

Написать программу вычисления силы тока в электрической цепи. ниже рекомендуемый вид экрана во время выполнения программы (данные, введенные пользователем, выделены полужирным шрифтом вычисление силы тока в электрической цепи. введите исходные данные: напряжение (вольт) -> 36 сопротивление (ом) -> 1500 сила тока: 0.024 ампер.

Информатика

Ответы

ОвсепянСергей88
#include <iostream> using namespace std; int main(){ float a,b,c; cout << "Введите исходные данные" << endl; cout << "Напряжение(вольт) -> "; cin >> a; cout << endl; cout << "Сопротивление(Ом) -> "; cin >> b; c = a / b; cout << "Сила тока: " << c << " Ампер" << endl; return 0; }
intermar2000

1 а XCIII б MMCXLVI 242919/2=21459 остаток 1

21459/2=10729 остаток 1

10729/2=5364 остаток 1

5364/2=2682 остаток 0

2682/2=1341 остаток 0

1341/2=670 остаток 1

670/2=335 остаток 0

335/2=167 остаток 1

167/2=83 остаток 1

83/2=41 остаток 1

41/2=20 остаток 1

20/2=10 остаток 0

10/2=5 остаток 0

5/2=2 остаток 1

2/2=1 остаток 0

1/2=0 остаток 1

Записав полученные цифры в ряд снизу вверх, получим:

4291910=10100111101001

восьмеричная

Приведем целую часть числа 42919 в систему счисления 8 последовательным делением на число 8:

42919/8=5364 остаток 7

5364/8=670 остаток 4

670/8=83 остаток 6

83/8=10 остаток 3

10/8=1 остаток 2

1/8=0 остаток 1

Записав полученные цифры в ряд снизу вверх, получим:

4291910=1236478

В итоге Получим решение:

4291910 =1236478

шестнадцатеричную

Приведем целую часть числа 42910 в систему счисления 16 последовательным делением на число 16:

42910/16=2681 остаток 14=E

2681/16=167 остаток 9

167/16=10 остаток 7

10/16=0 остаток 10=A

Записав полученные цифры в ряд снизу вверх, получим:

4291010=A79E16

В итоге Получим решение:

4291010 =A79E16

rina394992

Нужно заменить кусок кода на этот

double x = double.Parse(textBoxl.Text);

           double у = double.Parse(textBox2.Text);

           double z = double.Parse(textBox3.Text);

           

           //x = 0.1722;

           //y = 6.33;

           //z = 3.25;

           double a = 5.0 * Math.Atan(x);

           double b = 1.0 / 4.0 * Math.Acos(x);

           double c = x + 3.0 * Math.Abs(x - y) + Math.Pow(x, 2);

           double d = Math.Abs(x - y) * z * Math.Pow(10, -4) + Math.Pow(x, 2); double u = a - b * c / d;

           

           textBox4.Text += Environment.NewLine + "U = " + u.ToString("#.###");

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу вычисления силы тока в электрической цепи. ниже рекомендуемый вид экрана во время выполнения программы (данные, введенные пользователем, выделены полужирным шрифтом вычисление силы тока в электрической цепи. введите исходные данные: напряжение (вольт) -> 36 сопротивление (ом) -> 1500 сила тока: 0.024 ампер.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

art-03857
multikbo3049
Борисов
Алексей Кирилл1094
ekatef45
krasnobaevdj3
Никита
olegmgu1
Валентина980
orb-barmanager
spikahome
rigina82
titancore
AleksandrovnaIgor
elenaowchinik4842