rinan2013
?>

Смашиной дан массив меток. каретка обозревает первую пустую секцию перед началом массива. раздвиньте массив так, чтобы после каждой метки была пустая секция.

Информатика

Ответы

Ioanova Korneeva1093

Алгоритм такой:

1. Если массив закончился, завершить программу. Иначе к п.2

2. Освободить дырку справа

3. Найти правую границу массива, поставить там метку и вернуться к левой границе массива из оставшихся точек.

4. Вернуться к п. 1.

1.\hspace{1em} \rightarrow 2 \\
2.\hspace{1em} ? 15; 3 \\
3.\hspace{1em} \rightarrow 10 \\
4.\hspace{1em} X\hspace{0.5em} 5 \\
5.\hspace{1em} \rightarrow 6 \\
6.\hspace{1em} ? 7; 5 \\
7.\hspace{1em} V\hspace{0.5em} 8 \\
8.\hspace{1em} \leftarrow 9 \\
9.\hspace{1em} ? 1; 8 \\
10.\hspace{1em} ? 11; 4 \\
11.\hspace{1em} ! \\

rebet61
// PascalABC.Net 3.2
begin
  var a:=ArrRandom(15,10,30).Select(x->x+0.1); Write('A='); a.Println;
  var b:=ArrRandom(12,10,30).Select(x->x+0.1); Write('B='); b.Println;
  var c:=a.Intersect(b).ToArray;
  Write('C='); c.Println;
  a:=a.Except(c).ToArray; Write('A новый='); a.Println;
  b:=b.Except(c).ToArray; Write('B новый='); b.Println
end.

Пример решения
A=15.1 25.1 29.1 24.1 16.1 29.1 18.1 13.1 10.1 12.1 10.1 13.1 14.1 18.1 24.1
B=24.1 10.1 23.1 15.1 13.1 16.1 22.1 21.1 21.1 28.1 26.1 29.1
C=15.1 29.1 24.1 16.1 13.1 10.1
A новый=25.1 18.1 12.1 14.1
B новый=23.1 22.1 21.1 28.1 26.1
usmanovayanq2626
Using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;

namespace ConsoleApplication5
{
    class Program
    {
        static void Main(string[] args)
        {
            // 1) Написать программу,которая вводит таблицу квадратов первых 10 чисел.
            for (int i = 1; i <= 10; i++)
            {
                Console.WriteLine(i + "^2=" + Math.Pow(i, 2));
            }

            Console.ReadKey();

            // 2) Найти все натуральные числа а,b,с, из интервала от 1 до 10 для которых выполняется равенство а^2+b^2=c^2

            for (int a = 1; a <= 10; a++)
            {
                for (int b = 1; b <= 10; b++)
                {
                    for (int c = 1; c <= 10; c++)
                    {
                        if (Math.Pow(a, 2) + Math.Pow(b, 2) == Math.Pow(c, 2))
                            Console.WriteLine("a=" + a + "; b=" + b + "; c="+c);
                    }
                }
            }

            Console.ReadKey();
        }
    }
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Смашиной дан массив меток. каретка обозревает первую пустую секцию перед началом массива. раздвиньте массив так, чтобы после каждой метки была пустая секция.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

optikaleks7
Obukhov-Buriko
ooofishai4064
k-alexey9
info49
makashi28
olyavoznyak
alina-bas
Tatyana1374
aeykin
ulechkaevseeva
хуйдрочил_Анастасия
nestruev
Александровна1244
denchiklo2299667
▲