elbabitch2014
?>

Нужно написать программу, которая переводит десятичные числа в двоичные. на языке паскаль. !

Информатика

Ответы

svetlanam81

// PascalABC.NET 3.4.2, сборка 1785 от 06.09.2018

// Внимание! Если программа не работает, обновите версию!

begin

 var n := ReadInteger('Введите натуральное десятичное число:');

 var r: string := '';

 while n >= 2 do

   (r, n) := (n mod 2 + r, n shr 1);

 r := '1' + r;

 r.Println

end.

Pautova1119

Program l;

var

n: integer;

s: String;  

begin  

readln(n);  

while n>0 do begin  

insert(chr(48+n mod 2),s,1);  

n:=n div 2;  

end;  

writeln(s);  

end.


Нужно написать программу, которая переводит десятичные числа в двоичные. на языке паскаль. !
xeniagolovitinskaya4546

использовать Чертежник

алг

нач

цел в, г

вывод "Введите количество повторов по вертикали: "

ввод в

вывод "Введите количество повторов по горизонтали: "

ввод г

нц в раз

нц г раз

опустить перо

сместиться на вектор (0,1)

сместиться на вектор (1,0)

сместиться на вектор (0,-1)

сместиться на вектор (-1,0)

поднять перо

сместиться на вектор (-1,0)

опустить перо

сместиться на вектор (0,1)

сместиться на вектор (1,1)

сместиться на вектор (1,0)

сместиться на вектор (1,-1)

сместиться на вектор (0,-1)

сместиться на вектор (-1,-1)

сместиться на вектор (-1,0)

сместиться на вектор (-1,1)

поднять перо

сместиться на вектор (-1,0)

опустить перо

сместиться на вектор (0,1)

сместиться на вектор (2,2)

сместиться на вектор (1,0)

сместиться на вектор (2,-2)

сместиться на вектор (0,-1)

сместиться на вектор (-2,-2)

сместиться на вектор (-1,0)

сместиться на вектор (-2,2)

поднять перо

сместиться на вектор (5,0)

кц

сместиться на вектор (-(г*3),-3)

кц

кон

Объяснение:

картинка


3. Составьте программу рисования узора, показанного на рисунке. Количество повторений элементов узор
ZharikovZalina
Python

n = int(input())

s = []

result = [0,0,0]

for i in range(n):

   k = int(input())

   while not (-10000 < k < 10000):

       k = int(input("Out of range. Repeat: "))

   s.append(k)

for i in s:

   if i > 0:

       result[0] += 1

   elif i < 0:

       result[1] += 1

   elif i == 0:

       result[2] += 1

for i in result:

   print(i, end=" ")

Ввод/Вывод:

5                                                                                                                                

3                                                                                                                                

4                                                                                                                                

-4                                                                                                                              

-2                                                                                                                              

0                                                                                                                                

2 2 1

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужно написать программу, которая переводит десятичные числа в двоичные. на языке паскаль. !
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ГалинаРайгородская
Ивановна_Маликова1549
kolesnikovaen
Vyacheslavovich-Gubanov
yyyaga
supercom-ru-marinaguseva4267
Никита227
iv1as2
citioil15
Gulyaev_Egorkina
steff77
Lvova_Aleksandr933
sv-opt0076
ivanjeka87
mospaskrasnogorbukh
▲