Спивак
?>

Составить программу паскаль. ввести координаты двух точек на плоскости , на экран вывести номер четверти координатной плоскости. заранее

Информатика

Ответы

olarina6510

// PascalABC.NET 3.4.2, сборка 1785 от 06.09.2018

// Внимание! Если программа не работает, обновите версию!

procedure LocationPrint(x, y: real);

begin

 if x = 0 then

   if y = 0 then Writeln('Начало координат')

   else Writeln('Ось Y')

 else

 if y = 0 then Writeln('Ось X')

   else

 if x > 0 then

   if y < 0 then Writeln('Четвертая четверть')

   else Writeln('Первая четверть')

     else

 if y < 0 then Writeln('Третья четверть')

 else Writeln('Вторая четверть')

end;


begin

 loop 2 do

 begin

   var (x, y) := ReadReal2('Введите координаты x и y:');

   LocationPrint(x, y)

 end

end.

sargisyan77

Вот так например:

program find_quarter;

var x, y: real;

begin

read(x);

read(y);

if (x > 0) and (y > 0) then writeln('1')

else if (x < 0) and (y > 0) then writeln('2')

else if (x < 0) and (y < 0) then writeln('3')

else writeln('4');

end.


Составить программу паскаль. ввести координаты двух точек на плоскости ,на экран вывести номер четве
alexander4590

Используйте команду <img src="...">

Без атрибутов это будет выглядеть как <img src="моя_картинка.jpg">

путь до картинки должен быть относительно страницы сайты

ПРИМЕР:

страница сайта:  index.html  

картинка в том же каталоге где и сама страница, тогда <img src="моя_картинка.jpg"> , если рядом с index.html есть каталог "АрхивФото" и картинка в нем, тогда <img src="АрхифФото/моя_картинка.jpg">

Советую прочитать про атрибуты. Они правильно разместить картинку на странице.

Например

<img src="img/моя_картинка.jpg" align="left" vspace="10" border="3" alt="Названия моей картинки">

Означает что текст будет обтекать справа, отступ по ширине 10 пикселей, название картинки "Названия моей картинки"

Если конечно у вас будет присутствовать текст.

Vladimirovna

1. Математическая часть задачи.

Пусть a, b -- катеты ΔABC, а c -- гипотенуза.

1) Найдём катеты ΔABC:

ΔABC -- равнобедренный (по условию). => a = b.

c² = a² + b² (по теореме Пифагора)

c² = 2a²

a² = c² / 2

a = b = √(c² / 2)

2) Найдём радиус вписанной окружности:

r = (a + b - c) / 2 = (2a - c) / 2 = (2√(c² / 2) - c) / 2 = √(c² / 2) - c / 2

3) Найдём площадь вписанной окружности:

S = πR² = πr² = π(√(c² / 2) - c / 2)²

2. Код на Python

import math

c = int(input("Введите длину гипотенузы треугольника: "))

print(math.pi * (math.sqrt(c ** 2 / 2) - c / 2) ** 2)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу паскаль. ввести координаты двух точек на плоскости , на экран вывести номер четверти координатной плоскости. заранее
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

pivenraisa
rublevaoe392
Lapushkin1988
Kubataeva Nikolaevich1389
len22
DmitrievnaVera
dashasnegirva
fudan
arbat
seletan1
dpolkovnikov
ustinov434
eremenkou
sanhimki47
ogonizoloto
▲