kristinagaspa62
?>

Вс++ n школьников делят k яблок “поровну”, то есть так, чтобы количество яблок, доставшихся любым двум школьникам, отличалось бы не более, чем на 1. входные данные программа получает на вход числа n и k. выходные данные программа должна вывести количество школьников, которым достанется яблок меньше, чем некоторым из их товарищей. примечание при решении этой нельзя пользоваться условной инструкцией if и циклами. примеры входные данные 7 30 выходные данные 5 входные данные 7 28 выходные данные 0

Информатика

Ответы

irnik65

Ну, можно к примеру так сделать


Вс++ n школьников делят k яблок “поровну”, то есть так, чтобы количество яблок, доставшихся любым дв
Волков1968

1. a = int(input())

if a < 0:

   print('Отрицательное число')

elif a = 0:

   print(' ноль ')

else:

   print(' Положительное число') .

2. i = 0

while i != 5:

   i += 1

   print('8 класс')

3. i = [1,1,1,1,1]

for a in range(5):

   print('8 класс')

Объяснение:

Надеюсь вы так работали с циклом фор,а то у учительницы глаза на лоб вылезут). Вообще вот мое объяснение:
1. Сначала в питоне пишем переменную с оператором инпут для ввода числа, потом ставим условия if и elif, это одно и тоже но elif для множества условий. else - в противном случае. И там условия.

2. Берем переменную i(ее обычно используют для циклов) и пишу я: пока i не равно 5 учитывая что i равно 0 идет пять раз. А что бы шло пять раз надо дойти до 5 добавляя +1 к переменной.

3. Range функция арифмет. прогресии. Она считает сколько элементов в массиве и это использу. для цикла в цикле пишу 8 класс.

Учите пайтон - пайтон сила. А так хорошо размялся.

Volkanovaa19
// PascalABC.NET 3.0, сборка 1088
const
  nDay:array[1..12] of integer=(31,28,31,30,31,30,31,31,30,31,30,31);
type
  Date=record
    Day,Month,Year:integer
  end;
 
function DOW(Dat:Date):integer;
// день недели по дате. 0-Вс. 1-Пн, 7-Сб
var
  a,y,m:integer;
begin
  With Dat do begin
    a:=(14 - month) div 12;
    y:=Year-a;
    m:=month+12*a-2;
    DOW:=(7000+(day+y+y div 4-y div 100+y div 400+(31*m) div 12)) mod 7
    end
end;

procedure DMY2Date(d,m,y:integer; var data:Date);
// Преобразует к дате заданные день, месяц и год
begin
  data.Day:=d; data.Month:=m; data.Year:=y
end;

procedure LastDays(month,year:integer; var Wd,Fr:Date);
// даты последней среды (Wd) и пятницы (Fr) для месяца в году }
var
  LastDay:Date;
  n:integer;
begin
  n:=nDay[month];
  if (month=2) and (year mod 4 = 0) then Inc(n);
  DMY2Date(n,month,year,LastDay);
  n:=DOW(LastDay); // номер последнего дня недели
  Wd.Month:=month; Wd.Year:=year;
  if n<3 then Wd.Day:=LastDay.Day-(n+4)
  else
    if n=3 then Wd.Day:=LastDay.Day
    else Wd.Day:=LastDay.Day+3-n;
  Fr.Month:=month; Fr.Year:=year;
  if n<5 then Fr.Day:=LastDay.Day-(n+2)
  else
    if n=3 then Fr.Day:=LastDay.Day
    else Fr.Day:=LastDay.Day-1
end;

var
  Wd,Fr:Date;
  ff,mf:Text;
  m:integer;
begin
  Assign(ff,'father.txt'); Rewrite(ff);
  Assign(mf,'mother.txt'); Rewrite(mf);
  // Сентябрь-декабрь 2015 года
  for m:=9 to 12 do begin
    LastDays(m,2015,Wd,Fr);
    if Odd(Wd.Day) then Writeln(mf,Wd.Day,'.',m,'.2015 - 1 класс')
    else Writeln(ff,Wd.Day,'.',m,'.2015 - 1 класс');
    if Odd(Fr.Day) then Writeln(mf,Fr.Day,'.',m,'.2015 - 5 класс')
    else Writeln(ff,Fr.Day,'.',m,'.2015 - 5 класс')
  end;
  // Январь - май 2016 года
  for m:=1 to 5 do begin
    LastDays(m,2016,Wd,Fr);
    if Odd(Wd.Day) then Writeln(mf,Wd.Day,'.',m,'.2016 - 1 класс')
    else Writeln(ff,Wd.Day,'.',m,'.2016 - 1 класс');
    if Odd(Fr.Day) then Writeln(mf,Fr.Day,'.',m,'.2016 - 5 класс')
    else Writeln(ff,Fr.Day,'.',m,'.2016 - 5 класс')
  end;
  Close(ff); Close(mf)
end.

Содержимое выходных файлов:
father.txt
30.9.2015 - 1 класс
28.10.2015 - 1 класс
30.10.2015 - 5 класс
30.12.2015 - 1 класс
24.2.2016 - 1 класс
26.2.2016 - 5 класс
30.3.2016 - 1 класс

mother.txt
25.9.2015 - 5 класс
25.11.2015 - 1 класс
27.11.2015 - 5 класс
25.12.2015 - 5 класс
27.1.2016 - 1 класс
29.1.2016 - 5 класс
25.3.2016 - 5 класс
27.4.2016 - 1 класс
29.4.2016 - 5 класс
25.5.2016 - 1 класс
27.5.2016 - 5 класс

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Вс++ n школьников делят k яблок “поровну”, то есть так, чтобы количество яблок, доставшихся любым двум школьникам, отличалось бы не более, чем на 1. входные данные программа получает на вход числа n и k. выходные данные программа должна вывести количество школьников, которым достанется яблок меньше, чем некоторым из их товарищей. примечание при решении этой нельзя пользоваться условной инструкцией if и циклами. примеры входные данные 7 30 выходные данные 5 входные данные 7 28 выходные данные 0
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

md-masya
Nazaruk_Kodochigov
ElenaSkvortsova2
Пономаренко
Valeria123864531
сузанна_Людмила
Anatolii
smokestylemos
zsv073625
Fetyukov
mamanger
karasev17764
Хабарьева Андрей1056
zmlavra
elena-novikova-1992
▲