M19026789436
?>

Вуниверситете установлена определенная шкала перевода буквенной оценки в : буква a+ 4.0 a 4.0 a- 3.7 b+ 3.3 b 3.0 b- 2.7 c+ 2.3 c 2.0 c- 1.7 d+ 1.3 d 1.0 f 0 вам нужно написать программу, которая считает средний для любого количества введенных буквенных оценок. признаком конца ввода является символ q или q. пользователь может вводить оценки как строчными, так и прописными буквами. результат должен быть округлен до двух знаков после запятой при функции round. если в ответе остается один знак после запятой, то ноль выводить не следует. проверять ошибки ввода не следует, считайте, что ввод всегда корректен.

Информатика

Ответы

milleniumwood633

Ультразвуковые датчики – и уровнемеры, и сигнализаторы – широко применяются в самых разных сферах производства (в основном для жидких сред) за счет бесконтактного метода измерения уровня.

Излучатель

Наиболее распространены два вида излучателей: магнитострикционный и пьезоэлектрический.

Магнитострикционный — ультразвуковые колебания возникают при изменении линейных размеров ферромагнетика в переменном магнитном поле.

Пьезоэлектрический – ультразвуковые волны возникают при изменении линейных размеров диэлектрика, выполненного в виде мембраны, в переменном электрическом поле.

Объяснение:

priexali

1)

var

a: integer;

even,odd: byte;

begin

readln(a);

even := 0;

odd := 0;

while a > 0 do begin

 if (a mod 2) = 0 then

  even := even + 1

 else

  odd := odd + 1;

 a := a div 10;

end;

writeln('even: ', even);

writeln('odd: ', odd);

end.

2)

var

   n, m: longint;

   a: byte;

begin

   readln(n);

   m := 0;

   while n>0 do begin

       a := n mod 10;

       n := n div 10;

       m := m*10 + a;

   end;

   writeln(m);

readln;

end.

3)

var

   a,b,c,i,n: integer;

begin

   write('n = ');

   readln(n);

   a := 0;

   write(a,' ');

   b := 1;

   write(b,' ');

   for i:=3 to n do begin

       write(a+b,' ');

       c := b;

       b := a + b;

       a := c

   end;

readln

end.

Объяснение:


Проверочная работа. 1)ЗадачаНаписать программу, подсчитывающую количество четных и нечетных цифр в ч
Проверочная работа. 1)ЗадачаНаписать программу, подсчитывающую количество четных и нечетных цифр в ч
Проверочная работа. 1)ЗадачаНаписать программу, подсчитывающую количество четных и нечетных цифр в ч

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Вуниверситете установлена определенная шкала перевода буквенной оценки в : буква a+ 4.0 a 4.0 a- 3.7 b+ 3.3 b 3.0 b- 2.7 c+ 2.3 c 2.0 c- 1.7 d+ 1.3 d 1.0 f 0 вам нужно написать программу, которая считает средний для любого количества введенных буквенных оценок. признаком конца ввода является символ q или q. пользователь может вводить оценки как строчными, так и прописными буквами. результат должен быть округлен до двух знаков после запятой при функции round. если в ответе остается один знак после запятой, то ноль выводить не следует. проверять ошибки ввода не следует, считайте, что ввод всегда корректен.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Tane4ka2110
Umkatoys50
Ольга тимур
smirnovaL1286
sergeev-alp5
nadyatsoi
kuharhuks
vifslafes
Olegovich Nikolaevna
coffee2201
ГармаеваЕкатерина1637
AOS2015
tany821
mnkrasnova
suturinavaleriya51