Alekseeva_Khlistov
?>

Составьте программу, вычисляющую объем v куба и площадь s полной поверхности, если известна длина ребра a куба. вывод на экран оформить следующим образом: введите длину ребра куба в см: 2.5 объем куба равен 15.625 куб. см. площадь полной поверхности куба равна 37.5 кв. см.

Информатика

Ответы

Татьяна_Полулях

var b,c,a:real;

begin  

writeln('Введите длину ребра'); readln(a);

b:= sqr(a) * a;

c:= 6 * sqr(a);

writeln('Объем куба равен = ',b);

writeln('Площадь полной поверхности куба равна = ',c);

end.

elena

procedure SortFirstColAsc(p:array[,] of integer);

begin

 var c:=p.Col(0).OrderBy(x->x).ToArray;

 for var i:=0 to p.RowCount-1 do p[i,0]:=c[i]

end;

procedure SortLastColDesc(p:array[,] of integer);

begin

 var j:=p.ColCount-1;

 var c:=p.Col(j).OrderByDescending(x->x).ToArray;

 for var i:=0 to p.RowCount-1 do p[i,j]:=c[i]

end;

begin

 var n:=ReadInteger('Количество строк в матрице:');

 var m:=ReadInteger('Количество столбцов в матрице:');

 Writeln('*** Исходная матрица [',n,',',m,'] ***');

 var a:=MatrRandom(n,m,-99,99);

 a.Println(4); Writeln(4*a.ColCount*'-');

 Writeln('Сортировка по первой колонке');

 SortFirstColAsc(a);

 a.Println(4); Writeln(4*a.ColCount*'-');

  Writeln('Сортировка по последней колонке');

  SortLastColDesc(a);

 a.Println(4)

end.

Пример

Количество строк в матрице: 4

Количество столбцов в матрице: 7

*** Исходная матрица [4,7] ***

 -12  60  18 -46  10   4  26

 32 -73  -2 -88 -70 -46 -17

 -18  94 -41   9 -11  32  94

 32 -18   1 -71 -96 -77  46

Сортировка по первой колонке

 -18  60  18 -46  10   4  26

 -12 -73  -2 -88 -70 -46 -17

 32  94 -41   9 -11  32  94

 32 -18   1 -71 -96 -77  46

Сортировка по последней колонке

 -18  60  18 -46  10   4  94

 -12 -73  -2 -88 -70 -46  46

 32  94 -41   9 -11  32  26

 32 -18   1 -71 -96 -77 -17

Объяснение:

так?

Iselickaya1890
26 заглавных букв + 26 строчных букв + 10 цифр + 6 символов = 68 знаков используются в паролях.

Один такой знак занимает минимально 7 бит (2^6=64 < 68 < 128=2^7). 
Но символы кодируют целым числом байт. значит по 1 байту (8 бит) на символ. Длина пароля равна 12 символов, которые занимают 12 байт.

Всего выделено 1080 байт на 40 пользователей, то есть 1080/40 = 27 байт на одного пользователя.

Из них 12 байт занято под пароль. Остается 27-12=15 байт можно использовать для хранения дополнительных сведений о каждом пользователе

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, вычисляющую объем v куба и площадь s полной поверхности, если известна длина ребра a куба. вывод на экран оформить следующим образом: введите длину ребра куба в см: 2.5 объем куба равен 15.625 куб. см. площадь полной поверхности куба равна 37.5 кв. см.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

flerbuket332
ksv89
tvtanya80
bar02
antoha512
Ивановна_Маликова1549
tcmir
armynis8
Олегович Паутова
rimmatrotskaia303
d2002
marinadetsad
sbn07373
masha812
ayanrsadykov
▲