nikolai37
?>

Напишите программу, которая считывает слово (или фразу, неважно) и тут же выводит её, и больше ничего не делает. особое условие: необходимо написать эту программу в одну строчку, ограничившись 14 символами. язык : python

Информатика

Ответы

museumuzl

Смысла мало, но:

print(input())

14 символов

Aleksei368
Инфраструктура (infra - ниже, под и structura - строение, расположение)- комплекс взаимосвязанных обслуживающих структур или объектов, составляющих и/или обеспечивающих основу функционирования системы. Инфраструктура информационной системы (ИИС) близка к понятию интерфейса. Интерфейс - совокупность средств и методов взаимодействия между элементами системы. В зависимости от контекста, понятие интерфейса применимо как к отдельному элементу (интерфейс элемента), к связкам элементов (интерфейс сопряжения элементов), так и к системе. Под интерфейсом понимают не только устройства, но и правила (протокол) взаимодействия этих устройств.С позиций системного анализа инфраструктура может быть рассмотрена как система, тесно связанная с другой внутренней системой и служащая для ее обслуживания или эффективного функционирования. Отсюда следует, что как всякая система инфраструктура может иметь свой собственный интерфейс. Интерфейс инфраструктуры обладает своими признаками и может служить характеристикой самой инфраструктуры.Интерфейсы являются основой взаимодействия всех ИС. Если интерфейс какого-либо объекта (персонального компьютера, программы, функции) не изменяется (стабилен, стандартизирован), это даёт возможность модифицировать сам объект, не перестраивая принципы его взаимодействия с другими объектами. Это имеет прямое отношение к интерфейсу инфраструктуры. Если интерфейс ИС стабилен и стандартизирован, это даёт возможность модифицировать ИС и ее инфраструктуру, не перестраивая принципы взаимодействия с другими системами.Понятие инфраструктуры ближе к совокупности физических интерфейсов, как комплексу и взаимодействия физических устройств. Понятие интерфейса инфраструктуры ближе к понятию интерфейса пользователя (UI - user interface). UI - интерфейс, в котором одна сторона представлена человеком, другая - устройством. Представляет собой совокупность средств и методов, при которых пользователь взаимодействует с машинами, устройствами и инфраструктурами. Двунаправленный интерфейс применяет прямые и обратные информационные потоки. Поэтому под пользовательским интерфейсом подразумевается любая система взаимодействия с устройствами к интерактивному взаимодействию с пользователями.Особая связь между ИС и ее инфраструктурой приводит к тому, что интерфейс инфраструктуры (II) должен обладать особым признаком, которое называют дружественный интерфейс. Для этой цели за рубежом применяют термин «юзабилити быть использованным», «полезность»). В микроэргономике это понятие обозначает итоговый уровень применимости предмета в заявленных целях.Международный стандарт ISO 9241-11 определяет юзабилити как «the extent to which a product can be used by specified users to achieve specified goals with effectiveness, efficiency and satisfaction in a specified context of use» - «степень, с которой продукт может быть использован определёнными пользователями при определённом контексте использования для достижения определённых целей с должной эффективностью, продуктивностью и удовлетворённостью». При этом относительная важность всех трёх аспектов определяется этим самым контекстом.Однако, в реальной практике слово «юзабилити» нередко используется без учёта его значения в исходном английском и вне связи с международными. Как правило, это происходит из-за того, что игнорируется ключевой для контекста момент «определённости». Поэтому часто происходит так, что «интуитивная понятность» для разработчиков не является таковой для конечных пользователейПри разработке UI и II словом юзабилити обозначают общую концепцию удобства использования, логичность и простоту в расположении элементов управления.Применительно к информационной инфраструктуре термин «юзабилити» можно рассматривать как синоним слова «эргономичность» применительно к понятности элементов управления и режимов работы, к количеству и нужности функцийТаким образом, информационная инфраструктура должна иметь дружественный интерфейс как по отношению к пользователю, так и по отношению к ИС, которую она обслуживает. Это, в частности, определяет аспект защиты ИС с дружественного интерфейса ее инфраструктуры.
Сергей
uses crt;
var n: integer;
begin
write('Введите номер месяца: ');
readln(n);
case n of
1: writeln('январь');
2: writeln('февраль');
3: writeln('март');
4: writeln('арпель');
5: writeln('май');
6: writeln('июнь');
7: writeln('июль');
8: writeln('август');
9: writeln('сентябрь');
10: writeln('октябрь');
11: writeln('ноябрь');
12: writeln('декабрь');
else writeln('Нет такого месяца!');
end;
readkey end.

Программа на языке Pascal, могу ещё написать на с++ если надо...
P.S. Теперь лично для вас как работает. человек вводит число от 1 до 12, выводится соотвествующий месяц, если вводится число больше 12, то выведет "Нет такого месяца!", удачи!

Ввёл исправку в двух строчках. :)

Код на с++

#include <iostream>

using namespace std;

int main()

{
    int n = 0;

    cin >> n;

    if(n == 1)

    {
        cout << "January";
    }

    if(n == 2)

    {
        cout << "February";
    }
    if(n == 3)

    {
        cout << "Mart";
    }
    if(n == 4)

    {
        cout << "April";
    }
    if(n == 5)

    {
        cout << "May";
    }
    if(n == 6)

    {
        cout << "Iun";
    }
    if(n == 7)

    {
        cout << "Iul";
    }
    if(n == 8)

    {
        cout << "Augast";
    }
    if(n == 9)

    {
        cout << "September";
    }
    if(n == 10)

    {
        cout << "October";
    }
    if(n == 11)

    {
        cout << "November";
    }
    if(n == 12)

    {
        cout << "December";
    }
    if(n > 12)

    {
        cout << "Net takogo";
    }
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая считывает слово (или фразу, неважно) и тут же выводит её, и больше ничего не делает. особое условие: необходимо написать эту программу в одну строчку, ограничившись 14 символами. язык : python
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Maria095096
lazarevaavrora
andrew55588201824
Yuliya_Viktoriya316
mskatrinmadness
ivanpetrovichru1801
vitaldicky349
kobzev-e
Norov
Elshel8694
svetsalikowa
Sacharov84
mbobo28311
raa-0485428
Михайлов