Палкина-Дроздова
?>

Составить программу для нахождения поверхности сферы и объема шара. радиус шара r. на с#

Информатика

Ответы

dimanov

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Threading.Tasks;


namespace ConsoleApp9

{

   class Program

   {

       static void Main(string[] args)

       {

           Console.Write("r = ");

           double r = Convert.ToDouble(Console.ReadLine());

           Console.WriteLine("S = {0}", 4 * Math.PI * Math.Pow(r,2));

           Console.WriteLine("V = {0}", (4/3)*Math.PI*Math.Pow(r,3));



       }

   }

}


Составить программу для нахождения поверхности сферы и объема шара. радиус шара r. на с#
Составить программу для нахождения поверхности сферы и объема шара. радиус шара r. на с#
gameover98
Пусть чисел в отрезке N штук.
тогда сумма подряд идущих чисел, начиная с х будет равна
Sum = Nx + N*(N-1)/2
здесь второе слагаемое - это частичная сумма арифметической прогрессии 0,1,2,3...N
Максимальное значение N будет при нулевом x
1/2 (N - 1) N = 1014
N^2/2 - N/2 - 1014 = 0
N = 1/2 - sqrt(8113)/2 - нехороший корень
N = 1/2 + sqrt(8113)/2 - а это правильный, равный 45,53
Максимальное значение x будет при N=1
x = 1014, это тривиальное решение
Перебирать будем по N, просто меньше перебора
Nx + N*(N-1)/2 = 1014
Nx = 1014 - N*(N-1)/2
x =  1014/N - (N-1)/2 = (2028 - N(N-1))/(2N)
и проверять x на целостность

var 
  x,n,counter:longint;
begin
 counter:=0;
  for n:=1 to 45 do
    if (2028 - N*(N-1))mod(2*N) = 0 then 
    begin
      inc(counter);
      x := (2028 - N*(N-1))div(2*N);
      writeln ('x=',x,' N=',n);
    end;
  writeln('Всего решений ',counter);
end.

а отрезков 6
Belov Yekaterina639

Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу для нахождения поверхности сферы и объема шара. радиус шара r. на с#
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

cvetprint
emaykova785
mon84
Сергей_Крутикова114
Сергеевич1386
Pautova1119
lion13
KosarinPotemkina1888
ipKAV85
dyatchina63
mariavayda88734
Yelena Dilyara
IrinaSolodukhina1495
anadtacia03108988
Кириллов57