aleksey7800
?>

Pascalabc.net текстовый файл input.txt содержит натуральные числа. написать программу, которая создает текстовый файл output.txt, содержащий все четные числа файла input.txt в порядке возрастания.

Информатика

Ответы

Марина1101

Попробуй этот код

uses crt;

var f,g:text;

   a,max,min:integer;

begin

assign(f,'C:\in.txt');

assign(g,'C:\out.txt');

reset(f);

rewrite(g);

max:=0;

min:=0;

reset(f);

while not eof(f) do

     begin

     read(f,a);

     if a>max then max:=a;

     if a<min then min:=a;

     end;

writeln(g,'max ',max);

writeln(g,'min ',min);

close(f);

close(g);

end.

mupmalino2653

Классификация субъектов.

Можно выделить следующие виды субъектов информационного права:

— потребители (пользователи) информации, которыми согласно ст. 1 Федерального закона от 9 февраля 2009 г. № 8-ФЗ "Об обеспечении доступа к информации о деятельности государственных органов и органов местного самоуправления" являются граждане, организации, органы государства, органы местного самоуправления, общественные объединения, осуществляющие поиск информации, имеют право использовать информационные продукты в личных целях, обладают ограниченным правом на распространение информации;

— производители информации — лица, которые обладают всеми правомочиями в отношении создаваемых ими информационных продуктов;

— обладатели информации — лица, самостоятельно создавшие информацию либо получившие на основании закона или договора право разрешать или ограничивать доступ к информации (ст. 2 Федерального закона от 27 июля 2006 г. № 149-ФЗ "Об информации, информационных технологиях и о защите информации";

— информационные посредники, оказывающие информационные и иные услуги другим субъектам по отдельным договорам (операторы связи, сервис-провайдеры и др.). Среди них можно выделить традиционных информационных посредников и торговых информационных посредников [1]Торговые информационные посредники — это лица, осуществляющие посреднические информационные функции в сфере электронной торговли (торговое информационное посредничество).;

— органы надзора и контроля в сфере связи, информационных технологий и массовых коммуникаций, имеющие комплексную правосубъектность;

— юрисдикционные органы по рассмотрению информационных споров (вс органы).

Субъектов информационного права можно разделить на индивидуальных (физические лица) и коллективных (юридические лица). К индивидуальным относятся граждане, иностранцы, лица без гражданства, лица с двойным гражданством. Коллективные субъекты информационного права делятся на следующие виды: само государство; государственные органы и учреждения; общественные объединения; промышленные предприятия; иностранные фирмы; компании, банки. При этом не всякий коллектив может выступать субъектом права. Например, семья или кафедры, отделы и другие общности не обладают этим качеством. Субъектами информационного права являются устойчивые, постоянные образования, которые характеризуются единством воли и цели, а также определенной внутренней организацией, но не случайные и не временные объединения граждан.

Выделяют также основных (производитель, потребитель, обладатель информации) и вс субъектов информационного права (государственная комиссия по радиочастотам, конкурсные комиссии, судебные органы, рассматривающие информационные споры, и др.).

Модельный информационный кодекс для государств — участников СНГ устанавливает, что субъектами информационных отношений являются физические и юридические лица, лица без гражданства, общественные и политические организации, органы государственной власти и органы местного самоуправления. К субъектам также могут быть отнесены иностранные физические и юридические лица, иностранные общественные и политические организации, органы государственной власти и органы местного самоуправления иностранных государств, международные организации, иностранные государства (ст. 10).

Каждый из указанных субъектов имеет свой информационно-правовой статус на основании информационного законодательства.

Александровна1244

1)

using System;

using System.Collections.Generic;

using System.Collections.Specialized;

namespace ConsoleApp3

{

   class Program

   {

       static void Main(string[] args)

       {

           int num = Convert.ToInt32(Console.ReadLine());

           Console.WriteLine(num % 2 == 0 ? "Чётное" : "Нечётное");

           Console.WriteLine(num / 10 + num % 10);

       }

   }

}

2)

using System;

using System.Collections.Generic;

using System.Collections.Specialized;

namespace ConsoleApp3

{

   class Program

   {

       static void Main(string[] args)

       {

           double[] seconds = new double[8];

           string[] athletes = new string[8];

           double sum = 0;

           double maxN = 0;

           int max = 0;

           for (int i = 0; i < 8; i++)

           {

               Console.WriteLine($"Введите фамилию {i + 1}-го участника и его результат: ");

               athletes[i] = Console.ReadLine();

               seconds[i] = Convert.ToDouble(Console.ReadLine());

               sum += seconds[i];

               if (seconds[i] > maxN)

               {

                   maxN = seconds[i];

                   max = i;

               }

           }

           Console.WriteLine($"\n\nСредний результат участников - {sum / 8}");

           Console.WriteLine($"Лучший результат у участника с фамилией {athletes[max]} - {maxN}");

       }

   }

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Pascalabc.net текстовый файл input.txt содержит натуральные числа. написать программу, которая создает текстовый файл output.txt, содержащий все четные числа файла input.txt в порядке возрастания.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Коновалова
aa276568
shuxratmaxmedov
Борисовна
cat2572066
dimanov
АнжелаВасильевич
test43
aivia29
korolev-comitet8825
eutenkova805
rikki07834591
tcmir
Mariya dmitrievna
nataliaterekhovasinger2