krylova-natali
?>

Написать программу на c# перевести число из системы счисления с основанием a в систему с основанием b. можно считать, что 2 ≤ a, b ≤ 10, а число дано в виде массива цифр.

Информатика

Ответы

Anastasiya1537

Код и результаты работы на скриншоте. Работать будет для A и B меньших или равных 62. Дальше просто символов не придумал.


Написать программу на c# перевести число из системы счисления с основанием a в систему с основанием
Написать программу на c# перевести число из системы счисления с основанием a в систему с основанием
hachatryanlilit1983
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
begin
  var s:=ReadLines('in.txt').ToArray;
  var n:=StrToInt(s[0]);
  var a:=s[1].ToWords.Select(e->StrToInt(e)).ToArray;
  var f:=OpenWrite('out.txt');
  Writeln(f,n,' - (кол-во чисел)');
  foreach var e in a do Write(f,e,' '); Writeln(f);
  Writeln(f,'Среднее значение четных ',
    a.Where(x->x.IsEven).Average);
  Writeln(f,'Среднее значение нечетных ',
    a.Where(x->x.IsOdd).Average);
  f.Close
end.

Файлы in.txt и out.txt находятся во вложении.

Содержимое файла out.txt:
15 - (кол-во чисел)
-22 49 33 47 -10 -1 20 -18 2 21 2 -25 21 -47 -36
Среднее значение четных -8.85714285714286
Среднее значение нечетных 12.25
Umkatoys50
Рабо́чий стол (англ. desktop) — в компьютерной терминологии основное окно графической среды пользователя вместе с элементами, добавляемыми в него этой средой.

Обычно на рабочем столе отображаются основные элементы управления графической средой и, опционально, какое-либо фоновое изображение.

В некоторых рабочих средах (например, в MS Windows или в рабочих средах, удовлетворяющих требованиям freedesktop.org — KDE, GNOME и т. п.) с рабочим столом ассоциируется определённый каталог в файловой структуре компьютера (при этом обычно можно перетащить файл из стандартного для данной среды файлового менеджера на рабочий стол, и он будет туда скопирован). Ассоциированный каталог обычно находится в личной папке пользователя.

Так как рабочий стол практически всегда виден (либо его можно увидеть, свернув открытые окна), его используют для хранения часто использующихся файлов, документов и ссылок/ярлыков на них. Определение рабочего стола иногда расширяют, включая в него панель задач.

С точки зрения оконной системы рабочий стол может не являться окном низшего уровня (в системах Windows это можно заметить, завершив процесс «explorer.exe»).

Название «Рабочий стол» (точнее, «крышка рабочего стола», «столешница» — калька с англ. desktop) происходит от сравнения окон со стопкой бумаг, лежащих на столе.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на c# перевести число из системы счисления с основанием a в систему с основанием b. можно считать, что 2 ≤ a, b ≤ 10, а число дано в виде массива цифр.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

flerbuket332
fellybrossme
Радецкая264
benonika
irinakiral
ngz55
спец387
gorbunova188
Владимир
annarom1306
julia3594265843
pizniak
shuttse
optima3559
Andreevich