Филиппович_Николаевич
?>

Написать программу: ввести 10 чисел и посчитать количество чисел оканчивающихся на 3 (в паскаль)

Информатика

Ответы

devochkadafka624

begin

 ReadSeqInteger(10).Where(x -> x mod 10 = 3).Count.Println

end.

mishagoride885
Var a,k1,k2,s:integer;
begin
writeln('Вводите целые числа. Конец ввода - 0');
k1:=0;
k2:=0;
s:=0;
readln(a);
while a<>0 do
 begin
 if (a mod 2 = 0)and(a<0) then k1:=k1+1;
 if a mod 2 <> 0 then begin k2:=k2+1; s:=s+a; end;
 readln(a);
 end;
writeln('количество четных отрицательных чисел = ',k1);
if k2>0
 then writeln('среднее арифметическое нечётных чисел = ',s/k2)
 else writeln('в последовательности нет нечётных чисел');
end.

Пример:
Вводите целые числа. Конец ввода - 0
18
-45
10
-62
70
0
количество четных отрицательных чисел = 1
среднее арифметическое нечётных чисел = -45
afomin63
Var a,k1,k2,s:integer;
begin
writeln('Вводите целые числа. Конец ввода - 0');
k1:=0;
k2:=0;
s:=0;
readln(a);
while a<>0 do
 begin
 if (a mod 2 = 0)and(a<0) then k1:=k1+1;
 if a mod 2 <> 0 then begin k2:=k2+1; s:=s+a; end;
 readln(a);
 end;
writeln('количество четных отрицательных чисел = ',k1);
if k2>0
 then writeln('среднее арифметическое нечётных чисел = ',s/k2)
 else writeln('в последовательности нет нечётных чисел');
end.

Пример:
Вводите целые числа. Конец ввода - 0
18
-45
10
-62
70
0
количество четных отрицательных чисел = 1
среднее арифметическое нечётных чисел = -45

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу: ввести 10 чисел и посчитать количество чисел оканчивающихся на 3 (в паскаль)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

me576
master-lamaster
fotostock
Olga-Rauisovna
sbelova
asl09777
kozak8824
vrn3314
Kubataeva Nikolaevich1389
сергей1246
Vladimirovich351
preida-2
miheev-oleg578
tatiana2676
Борисовна_Дмитриевич1003