svetkinm158
?>

Pascal. составить программу для вычисления значений функции f(x) на отрезке [а, ь] с шагом /г. результат представить в виде таблицы, первый столбец которой — значения аргумента, второй — соответствующие значения функции. 24.f(x)= tg2x-3.

Информатика

Ответы

Yezhov_igor42

begin

 var (a, b, h) := ReadReal3();

 var F: Func<real, real> := x -> Tan(2 * x) - 3;

 var x := a;

 repeat

   Writeln(x:3:1, F(x):10:6);

   x += h;

 until x > b;

end.

Салиев
1. Записывает введенное пользователем значение в переменную dr
2. integer
3. sqrt(число)
4. var
5. 16
6. 2
7.
function x(a,b,c:integer);
begin
x:=-b+sqr(b)-sqr(4*a*c)*a;
end;
8. 11
9. end.
10. d)
11.
var a,b,c:integer;
result:real;
begin
readln(a,b,c);
result:=(a*b*c)/3;
writeln(result:0:3);
end.
12. real
13. оператор присвоения
14. Присвоить переменной F значение 125
15. write(B); или writeln(B);
16. корень из суммы квадрата х и ста делить на разность а и b умноженной на с
17. с)
18. Нет картинки как образован массив, значит сами решите
19. d)
20. c)
21. c)
Irina Svetlana
//Язык Pascal

Program Test;

var
Mas: array[1..10] of integer;
result1: integer;
result2: real;

function Sum(): integer;
var summa: integer;

begin
summa := 0;

for var i := 1 to 10 do
summa := summa + Mas[i];

Sum := summa;
end;

procedure Arifmetic(r1: integer; var A: real);
begin
A := r1 / 10;
end;

Begin

for var i := 1 to 10 do
begin
Write('Введите ', i, ' элемент: ');
Readln(Mas[i]);
end;

result1 := Sum();
Arifmetic(result1, result2);

Writeln();
Writeln('Сумма = ', result1);
Writeln('Среднее арифметическое = ', result2);

End.
Написать программу на паскале, которая будет считать сумму и среднее арифметическое 10 чисел, введен
Написать программу на паскале, которая будет считать сумму и среднее арифметическое 10 чисел, введен
Написать программу на паскале, которая будет считать сумму и среднее арифметическое 10 чисел, введен

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Pascal. составить программу для вычисления значений функции f(x) на отрезке [а, ь] с шагом /г. результат представить в виде таблицы, первый столбец которой — значения аргумента, второй — соответствующие значения функции. 24.f(x)= tg2x-3.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

komarov-dmitriy
Tatianamir765654
Yezhov_igor42
Natalimis416024
lenarzhaeva
Verakravez8790
kifstd
AlekseiMardanova
oooviktoria17
nevzorova
Yekaterina
Sergeevich-irina
myudanova631
Devaunka40
Lenuschakova1982316
▲