igschuschkov6211
?>

А) составьте программу, которая позволяет найти, вывести на экран первое слово строки s. строку s, состоящую из слов, разделенных пробелов, введите с клавиатуры. б) составьте программу, которая позволяет найти, вывести на экран второе слово строки s.строку s, состоящую из двух слов, разделенных пробелом, введите с клавиатуры.

Информатика

Ответы

Smirnovav1982422
PascalABC.NET 3.4.2, сборка 1837 от 11.10.2018Внимание! Если программа не работает, обновите версию!

begin

 var s:=ReadlnString.ToWords;

 a[0].Println; // 1-е слово

 a[1].Println // 2-е слово

end.

Дмитрий_Евлампиев518
Язык не указан, поэтому запишу на универсальном языке. Потом просто подставите в свой язык.

x = длинна массива A1
y = длинна массива A2
z = длинна массива A3

цикл i от 0 до x:
    если i<=0:
        B1[0] = B1[0] + 1
    иначе:
        B1[1] = B1[1] + 1

цикл i от 0 до y:
    если i<=0:
        B2[0] = B2[0] + 1
    иначе:
        B2[1] = B2[1] + 1

цикл i от 0 до z:
    если i<=0:
        B3[0] = B3[0] + 1
    иначе:
        B3[1] = B3[1] + 1

Вот и все.
Можно было объединить эти 3 цикла в один двойной цикл, однако это работает не во всех языках.
lzelenyi5
Const
  nn=50; // максимальное количество учеников
var
  i,n,sm,sd,km,kd:integer;
  am,ad:real;
  var a:array[1..nn] of integer;
begin
  Write('Введите количество учеников: ');
  Read(n);
  Writeln('Введите рост учеников');
  sm:=0; sd:=0; km:=0; kd:=0;
  for i:=1 to n do
    begin
    Read(a[i]);
    if a[i]>0 then begin sd:=sd+a[i]; Inc(kd) end
    else begin sm:=sm-a[i]; Inc(km) end
    end;
  am:=sm/km; ad:=sd/kd;
  Write('Средний рост мальчиков (',am:0:1,') ');
  if am-ad<=10 then Write('не ');
  Writeln('превышает средний рост девочек (',ad:0:1,') ');
  Writeln('больше, чем на 10 см')
end.
   
Примерное решение

Введите количество учеников: 9
Введите рост учеников
-192 165 -174 179 -172 171 169 170 -170
Средний рост мальчиков (177.0) не превышает средний рост девочек (170.8)
больше, чем на 10 см

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

А) составьте программу, которая позволяет найти, вывести на экран первое слово строки s. строку s, состоящую из слов, разделенных пробелов, введите с клавиатуры. б) составьте программу, которая позволяет найти, вывести на экран второе слово строки s.строку s, состоящую из двух слов, разделенных пробелом, введите с клавиатуры.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

zhandarmova
IInessa44478
ss2911
Lvova_Aleksandr933
annapiskun1
amarantmetall
zubareva23338
ganzashop
korotaeva778898
gav973
Дружинин
mnkrasnova
Диана820
Reznikova1075
goldglobustour725