oniks-plus
?>

Составить программу на языке с# дан массив из случайных чисел. нужно переписать элементы, большие среднего арифметического, в начало, а остальные - в конец массива. выполнить с использованием второго массива

Информатика

Ответы

Есартия52

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Threading.Tasks;


namespace avg_sort

{

   class Program

   {

       static void Main(string[] args)

       {

           const int N = 10;

           int[] Arr = new int[N];


           Random rand = new Random();

           Console.Write("Исходный массив: ");

           for (int k = 0; k < N; ++k)

           {

               Arr[k] = rand.Next() % 100;

               Console.Write("{0} ", Arr[k]);

           }

           Console.WriteLine();


           double avg = Arr.Average();

           int[] Bufer = new int[N];

           int i = 0, j = N - 1;


           Console.WriteLine("Среднее значение по массиву Avg = {0}", avg);

           for (int k = 0; k < N; ++k)

           {

               if (Arr[k] > avg)

               {

                   Bufer[i] = Arr[k];

                   i++;

               } else

               {

                   Bufer[j] = Arr[k];

                   j--;

               }

           }

           Arr = Bufer;


           Console.Write("Отсортированный массив: ");

           foreach (var el in Arr)

           {

               Console.Write("{0} ", el);

           }

           Console.WriteLine();

       }

   }

}



Составить программу на языке с# дан массив из случайных чисел. нужно переписать элементы, большие ср
beglovatatiyana

Учебный проект – организационная форма работы, которая ориентирована на усвоение учебной темы или учебного раздела и является частью стандартного учебного предмета или нескольких предметов.  

  Любая работа над темой или просто групповая работа не может называться методом проектов. Метод проектов предусматривает совокупность учебно-познавательных приемов, которые позволяют решить ту или иную проблему путем самостоятельных действий учеников с обязательной презентацией (представлением) полученных результатов.

  Проектное обучение сформировать так называемый проектировочный стиль мышления, который соединяет в единую систему теоретические и практические составляющие деятельности человека, позволяет раскрыть, развить, реализовать творческий потенциал личности.

Объяснение:

sahar81305

Вот

Объяснение:

                                                 начало

                                                       |

                                         подойди к дороге

                                                       |

                                      посмотри на светофор

                                                        |

                                          цвет зелёный?

                                             |                    |

                                       если да          если нет

                                             |                     |

                                           иди               стой

                                              \                     /

                                             конец алгоритма

Запиши в виде этой схемы

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу на языке с# дан массив из случайных чисел. нужно переписать элементы, большие среднего арифметического, в начало, а остальные - в конец массива. выполнить с использованием второго массива
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

bogatskayaa
Юрьевна174
Olga-Rauisovna
novkatrina
Roman913
Test Станислав
Сергеевич1396
zyf0066
Тресков946
Bella Sergei
Chopper-hinter25
Оксана Анна
Vs1377
Абдулганиева Сергей
nuralievelsh