Напишите программу (python), которая соберет все подарки Иа от всех друзей.
Формат ввода
Целое число — количество строк, затем сами строки, в которых сначала вводится подарок, а потом через дефис, окруженный пробелами, имя друга.
Формат вывода
Вывести для каждого друга (друзья выводятся в обратном алфавитном порядке) список его подарков Иа, но уже в алфавитном порядке. Формат вывода:
Друг: подарок, подарок, подарок
Ввод
5
Букет из чертополоха - Кролик
Бант для хвоста - Кристофер Робин
Гвоздик для хвоста - Кристофер Робин
Спаржевый пудинг - Кролик
Зеленая тряпочка - Пятачок
Вывод
Пятачок: Зеленая тряпочка
Кролик: Букет из чертополоха, Спаржевый пудинг
Кристофер Робин: Бант для хвоста, Гвоздик для хвоста
Розы - 38 млн. , пионы - 3 млн. , розы AND пионы - 4 млн. , розы OR пионы - 2 млн. , -розы пионы 4 млн.
Человек-
чтение газеты человеком
строительство дома людьми
Общение с друзьями
Хождение в ресторан
Игра в волейбол
Животный мир-
принятие определённой позы собакой при приближении соперника
общение дельфинов между собой
виляние хвостом у собак
Беганье за палкой
Игра волчат
Растительный мир-
Опадение листвы
рост побегов
сезонные изменения в природе
Начало дождя
Рост дерева
Технические системы-
вождение автомобиля
Деланье уроков
гулянка
Стройка самолета
Готовка еды в массовом производстве
Поделитесь своими знаниями, ответьте на вопрос:
Заполнить массив [x, y] случайными двузначными числами, распечатать в табличном виде, а затем транспонировать (строки сделать столбцами, а столбцы строками) и распечатать рядом с первым массивом. язык с# " console.write("введите диапазон массива x = "); int x = convert.toint32(console.; console.write("введите диапазон массива y = "); int y = convert.toint32(console.; int[, ] m = new int[x, y]; random r = new random(); for (int j = 0; j < y; j++) { for (int i = 0; i < x; i++) { m[i, j] = r.next(10, 99); console.write(m[i, j] + "\t"); } console.writeline(); } console.writeline(); /*for (int i = 0; i < x; i++) { for (int j = 0; j < y; j++) { где-то тут ошибка исправить или написать новую программу console.write(m[j, i] + "\t"); } console.writeline(); }*/ console.readkey(); "
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
namespace KekTus
{
class Program
{
static void PrintArr(int[][] arr)
{
foreach (var str in arr)
{
foreach (var el in str)
Console.Write($"{el}\t");
Console.WriteLine();
}
}
static void Main(string[] args)
{
int M;
int N;
try
{
Console.Write("M = "); M = int.Parse(Console.ReadLine());
Console.Write("N = "); N = int.Parse(Console.ReadLine());
}
catch
{
Console.WriteLine("Ошибка ввода");
return;
}
if (N < 0 || M < 0)
{
Console.WriteLine("Ошбка ввода");
return;
}
int[][] Arr = new int[M][];
var rand = new Random();
for(int i = 0; i < M; ++i)
{
Arr[i] = new int[N];
for (int j = 0; j < N; ++j)
Arr[i][j] = rand.Next(10,99);
}
Console.WriteLine("Исходный массив:");
PrintArr(Arr);
Console.WriteLine();
int[][] Buffer = new int[N][];
for (int j = 0; j < N; ++j)
Buffer[j] = new int[M];
for (int i = 0; i < M; ++i)
for (int j = 0; j < N; ++j)
Buffer[j][i] = Arr[i][j];
Arr = Buffer;
Console.WriteLine("Преобразованный:");
PrintArr(Arr);
Console.WriteLine();
}
}
}