kate281078
?>

Написать программу в паскаль. расстояние между пунктами а и b равно r. из пункта а в пункт b выезжает машина со скоростью v1. одновременно из пункта b в пункт а навстречу выезжает ещё одна машина со скоростью v2. определите расстояние r1 между машинами через один час. определите через какое время машина встретятся. в паскаль

Информатика

Ответы

salesrawtogo

Смотри решение во вложении


Написать программу в паскаль. расстояние между пунктами а и b равно r. из пункта а в пункт b выезжа
korotaeva778898

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

28

29

30

31

32

33

34

35

36

37

38

39

40

41

42

43

44

45

46

47

48

49

50

51

52

53

54

55

#include "stdafx.h"

#include "stdio.h"

#include <time.h>

#include <stdlib.h>

class vector

{

private:

int* m;

int size;

public :

vector(int n = 0);

vector(const vector &vector2);

~vector();

};

vector::vector( int n )

{

if (n < 0) n = 0;

size = n;

m = new int[n];

if(!m)

printf("Error");

else

m = NULL;

}

vector::vector(const vector &vector2)

{

size = vector2.size;

m = new int [size];

for(int i = 0; i<size;i++)

m[i] = vector2.m[i];

printf("Hello world !");

}

vector::~vector()

{

delete[] m;

}

vector(int *m, int size)

{

srand(time(NULL))

if(!m)

printf("error")

else

for(int i = 0; i < size; i++)

m[i] = rand()% 99;

}

int main()

{

vector v1(45),

system("pause");

return 0;

}

Так?

Irina
// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
begin
  var n:=ReadInteger('Введите четырехзначное число');
  Writeln('В числе');
  Writeln(n div 1000,' - тысяч');
  Writeln((n div 100) mod 10,' - сотен');
  Writeln((n mod 100) div 10,' - десятков');
  Writeln(n mod 10,' - единиц')
end.

Тестовое решение:
Введите четырехзначное число 4072
В числе
4 - тысяч
0 - сотен
7 - десятков
2 - единиц

// PascalABC.NET 3.1, сборка 1219 от 16.04.2016
begin
  var n:=ReadInteger('Введите трехзначное число');
  var s:=n div 100;
  var d:=(n div 10) mod 10;
  var e:=n mod 10;
  Writeln('Sum=',s+d+e);
  Writeln(e,d,s);
  Writeln('В числе');
  Writeln(e,' - сотен');
  Writeln(d,' - десятков');
  Writeln(s,' - единиц')
end.

Тестовое решение:
Введите трехзначное число 492
Sum=15
294
В числе
2 - сотен
9 - десятков
4 - единиц

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу в паскаль. расстояние между пунктами а и b равно r. из пункта а в пункт b выезжает машина со скоростью v1. одновременно из пункта b в пункт а навстречу выезжает ещё одна машина со скоростью v2. определите расстояние r1 между машинами через один час. определите через какое время машина встретятся. в паскаль
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

household193
marinamarinyuk39
МАМОНОВА-андрей
misstimarina2016
mariavayda88734
Gradus469
ПодлеснаяМакарова1883
pristav9
dokurova634
helenavalenti2846
Бурмистров_Салагин1074
Выберите верные утверждения? "&gt;
lezzzzka5510
zoyalexa495
andreevaanastsiyao82
yaart-klementiev29