edvlwork15
?>

Напишите программу на с++, нужно. вася, петя и коля играли в теннис навылет (проигравший пропускал следующую партию, уступая свое место третьему вася утверждает, что сыграл x партий, петя – что сыграл y партий, коля – z партий. определите, могло ли такое быть.

Информатика

Ответы

rayman777
Некоторые условияСкорее, главное условие - это чётность игр. Поскольку в партии играет по двое, то сумма чисел должна быть чётной. Код

#include <iostream>

using namespace std;

int main()

{

   unsigned int x, y, z;

   cin >> x >> y >> z;

   if((x + y + z) % 2 == 0){

       if((3*z + 2 >= x + y) || (3 * x + 2 >= y + z) || (3 * y + 2 >= x + z)){

           cout << "YES";

           return 0;

       }

   }

   else{

       cout << "NO";

       return 0;

   }

   return 0;

}

Проверка

2 2 2                                                                                                

YES

3 1 2                                                                                                

YES

1 1 1                                                                                                

NO

Arzieva Abdulmanov1438

Консольные программы — это наследие старых операционных систем типа MS DOS, работавших в текстовом режиме. Полной аналогии здесь нет, но создатели систем разработки пытаются сделать всё, чтобы было максимальное сходство. Для консольной программы операционная система или система разработки предоставляет специальное окно (обычно — черного цвета), в котором виден ход выполнения программы.

Оконное приложение всегда имеет своё собственное окно (обычно его называют главным окном приложения). Кроме главного окна в приложении могут использоваться множество других окон.

При разработке оконного приложения используются различные элементы управления: командные кнопки, окна ввода, надписи, меню и т.д.

machkura

Номер 1

использовать Робот

алг

нач

нц пока сверху свободно

вверх

кц

нц пока сверху стена

закрасить

влево

кц

нц пока сверху не стена

влево

кц

нц пока сверху стена

закрасить

влево

кц

вверх

вправо

нц пока снизу стена

закрасить

вправо

кц

нц пока снизу не стена

вправо

кц

нц пока снизу стена

закрасить

вправо

кц

кон

Номер 2

использовать Робот

алг

нач

нц пока сверху стена

закрасить

влево

кц

вправо

нц пока сверху стена

если справа не свободно то

вправо

все

если справа свободно то

вправо

если сверху стена то

закрасить

все

все

кц

влево

нц пока снизу не стена

вниз

кц

нц пока слева не стена и снизу стена

закрасить

влево

кц

кон

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу на с++, нужно. вася, петя и коля играли в теннис навылет (проигравший пропускал следующую партию, уступая свое место третьему вася утверждает, что сыграл x партий, петя – что сыграл y партий, коля – z партий. определите, могло ли такое быть.
Ваше имя (никнейм)*
Email*
Комментарий*