delena6467
?>

Составьте программу заполнения массив 15 случайных вещественных чисел из промежутка [2: 3) вывода массива в строке с тремя десятичными знаками форматный вывод

Информатика

Ответы

Natalimis416024
PascalABC.NET 3.4.2, сборка 1837 от 11.10.2018Внимание! Если программа не работает, обновите версию!

begin

 var a := ArrRandomReal(15, 2, 3 - 1e-15);

 a.Select(t -> Round(t, 3)).Println

end.

2.777 2.692 2.943 2.469 2.085 2.212 2.522 2.286 2.255 2.602 2.898 2.178 2.677 2.826 2.664
myataplatinumb348
Блок схемы не очень момню поэтому заменил блоки тэгами. Надеюсь, понятно.

<блок начало> Начало
<блок ввода данных> Ввести А, B </блок>
<блок действия> C:=(A+B)/2 </блок>
<блок дествия> D:=2*A*B</блок>
<блок проверки условия> A<b?</блок>
<если да>
<блок действия> A:=C</блок>
<блок дествия>B:=D</блок>
</если>
<если нет>
<блок действия> B:=C</блок>
<блок дествия>A:=D</блок>
</если>
<блок вывода>Вывести A,B<блок вывода>
<блок конца>Конец </блок>
inna-zub
Не хватает либо цены за билет эконом класса
либо цены за билет бизнес класса.

Uses crt;
var a,b,x,c,d:real;
begin
ClrScr;
writeln('Введите кол-во нераспроданных билетов бизнес класса (а) и кол-во нераспроданных билетов эконом. класса (б) ');
readln(a,b);
// Узнали, сколько осталось нераспроданных билетов разных классов.
c:=160*0.75-b;
// Узнали, сколько билетов продано эконом класса.
d:=160*0.25-a;
// Узнали, сколько билетов продано бизнес класса.
x:=d+c/2;
writeln('Для того, чтобы узнать сколько денег получила авиакомпания за этот рейс нужно число х: ',x,' умножить на цену билета бизнес класса, либо умножить на удвоенную цену одного билета эконом класса');
readln
end.

Или ответ: число которое выведет программа х, например, ответ: 15х

Программа проверена, если что не так пиши

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу заполнения массив 15 случайных вещественных чисел из промежутка [2: 3) вывода массива в строке с тремя десятичными знаками форматный вывод
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Fedorovna
N-odes-art-school410
monolit-kolomna
Svetlana191
georgegradoff122
aeykin
bagrjashv41
Angelina1139
macmakka
nkaminskaja
Раисовна878
seymurxalafov05
Анатольевна824
tatiyanabe2013727
garikman-flesh486
▲