aleksey7800
?>

Заданы два целых числа a и b. составьте программу, определяющую, сколько целых чисел, которые одновременно удовлетворяют двум неравенствам x> a и x

Информатика

Ответы

avn23

var a,b:integer;

begin

readln (a,b);

if a<b then write (b-1-a) else write(0)

end.

Анатольевна824

Ввод: a ^ b С/П.

- x>=0 05 0 С/П /-/ 1 - С/П


Согласен, отрицательный результат противоречит условию, исправил. Благодарю за замечание, был невнимателен.

Смысл кода такой:

X = a; Y = b;

X -= Y; Если не (X >= 0), переход на 05; X = 0; Стоп; [05] Смена знака; Y = X, X = 1; X -= Y; Стоп. На индикаторе X.

Рад, что мои решения кому-то интересны.

armusaeff

1. Вкладки  --- H. переключение между ними осуществляется щелчком мыши по их названию, на них размещаются элементы управления

2. Текстовые поля  --- E. служит для ввода последовательности символов

3. Списки  --- F. представляет собой набор значений и выглядит как текстовое поле, снабженное кнопкой с направленной вниз стрелкой

4. Переключатели  --- C. служат для выбора одного из взаимоисключающих вариантов

5. Флажки  --- G. обеспечивают присваивание какому-либо параметру определенного значения и могут располагаться как группами, так и поодиночке

6. Счетчики  --- A. представляет собой пару стрелок, которые позволяют увеличивать или значение в связном с ним поле

7. Ползунки  --- D. позволяет плавно изменять значение какого-либо параметра

8. Командные кнопки  --- B. щелчок по ним обеспечивает выполнение того или иного действия, а надпись на них поясняет назначение

marusyamr
Правильно пишется шестнадцатеричный. 
При переводе 2⇒16 число справа налево делится на группы из 4 цифр каждая, затем каждая группа заменяется на шестнадцатеричную цифру:
1000111111₂ = 10 0011 1111₂ = 23F₁₆
При переводе 10⇒12 число надо делить на 12 и выписать остатки от деления в обратном порядке. Остаток 10 заменить на A, остаток 11 - на B
923₁₀ = 64B₁₂
Два последних примера лучше делать за 2 действия: сначала перевести в 10-ю систему счисления, а потом - в 5 (или 12)
79₁₆ = 121₁₀ = 441₅
1050₈ = 552₁₀ = 3A0₁₂

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Заданы два целых числа a и b. составьте программу, определяющую, сколько целых чисел, которые одновременно удовлетворяют двум неравенствам x> a и x
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kapustina198690
amarantmetall
nalekseeva62
Камочкин
megapolisgroup
parolmm
Yurevich
Chopper-hinter25
АннаМаргарита
Виктор Попова
Вычислите ((0&amp;0) V0) &amp; (1V0)
Mikhail579
sky-elena712558
Александра-Андрей909
Goldaram84
maglevanyycpt