proea
?>

Составьте программу, которая осуществляет ввод в массив с клавиатуры размеров 6 файлов в байтах ( от 100 до 2000) и выселяет: а) суммарный размер файлов в килобайтах ; б) средний размер файла. ,

Информатика

Ответы

Olenkalebedeva4477

javascript:var массив = []; for (let сч = 1; сч <= 6; сч++) массив.push(parseInt(prompt(сч + ":"))); var сумма = массив.reduce(function(s, c) {  return s + c;  }, 0) / 1000, среднее = сумма / массив.length; alert("Среднее: " + среднее + ", сумма: " + сумма + ".");


Обрати внимание на то, что килобайт - это ровно тысяча байтов (см. ГОСТы по электросвязи).

Verakravez8790

1 задача:

import math

a=int(input())

b=int(input())

if(math.fabs(a+b)>20):

   print(math.pow(a,2))

else:

   b=math.fabs(b)

   print(math.sqrt(b))

2 задача:

a=int(input())

if a == 5:

   print("Отлично")

elif a == 4:

   print("Хорошо")

elif a == 3:

   print("Удовлетворительно")

elif a == 2:

   print("Плохо")

elif a == 1:

   print("Отвратительно")

else:

   print("Это не оценка")

3 задача:

x=int(input())

y=int(input())

a=int(input())

b=int(input())

a7 = a%x

b7 = b%y

if(a7>b7):

   print("7A")

else:

   print("7Б")

4 задача:

import math

print("Введите интервал")

a=int(input())

b=int(input())

while(a<=b):

   if a<100:

       r=13*math.pow(a,2)

       print("X=" + str(a) + " y=" + str(r))

   elif a>100:

       r=math.pow(a,3)-100

       print("X=" + str(a) + " y=" + str(r))

   else:

       r=30-(a/(a-5))

       print("X=" + str(a) + " y=" + str(r))

   a=a+1

5 задача:

import math

print("Введите интервал")

a=int(input())

b=int(input())

while(a<=b):

   if a<4:

       r=3*a-7

       print("X=" + str(a) + " y=" + str(r))

   else:

       r=5*math.pow(a,2)

       print("X=" + str(a) + " y=" + str(r))

   a=a+1

Объяснение:

proplenkusale88

a = int(input())

for i in range(a):

 b = input()

 c = 0

 d = True

 e = 0

 f = False

 g = False

 h = '\''

 for j in b:

   if j == '#' and not f:

     g = True

     break

   elif j != ' ':

     if d:

       print(' ' * c, end='')

     elif c > 0:

       print(' ', end='')

     c = 0

     print(j, end='')

     if(j == '\"' or j == '\'') and e % 2 == 0:

       if f and j == h:

         f = False

       else:

         f = True

         h = j

     if f:

       d = True

     else:

       d = False

     if j == '\\':

       e += 1

     else:

       e = 0

   else:

     c += 1

   r = j == ' '

if g and c > 1:

 print(' ', end='')

if i < a - 1:

 print()

1

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, которая осуществляет ввод в массив с клавиатуры размеров 6 файлов в байтах ( от 100 до 2000) и выселяет: а) суммарный размер файлов в килобайтах ; б) средний размер файла. ,
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

nikitavertiev98400
Шаленко
kolefe22171
Стуканова УЧРЕЖДЕНИЕ1877
zoosalon-hollywood5
marketing3
Казаков
Fedorovich_Aleksandrovich685
Олегович Паутова
Александровна
afilippov3321
​
mstapottery
uuks2012
manager6
amxvel7596
▲