tarkhanovilya
?>

Составить программу вычисления суммы всех натуральных чисел, меньших м, в записи которых нет парных цифр. использовать функцию определения количества парных цифр в числе. язык c++

Информатика

Ответы

Абумислимовна_кооператив585

#include <iostream>

using namespace std;

int sum( int n  ){

   int k = 0;

   int t = n;

   while ( t > 0 )

   {

       if ( ( t % 10 ) % 2 == 0 )

           k++;

       t /= 10;

   }

   return k;

}

int main()

{

   int  M,S,p;

   cin  >> M;

   S = 0;

   for ( int i = 1; i < M; i++ ){

    p = sum(i);

       if ( p == 0 ) {

           S = S + i;

       }

   }

   cout << S;

   return 0;

}

tonyakuznetsova
Сочетание Ctrl + --> это прыжок на начало следующего слова.
Сочетание Ctrl + Del это удалить часть слова от курсора до пробела.
Если курсор стоит перед 1 буквой - удалится всё слово.
1) Нажимаем 2 раза Ctrl + --> и попадаем на скобку "(".
2) Нажимаем 6 раз Ctrl + Del и удаляем: скобку "(", 4 слова в скобках,
и скобку ")".
3) Получили "словможно". Теперь нужно нажать пробел, чтобы разделить слова: "слов можно"
ответ: 3) 1 клавишу и 8 сочетаний.
Как вы за компьютером работаете, если MS Word не знаете?
sharovaeln6

Первая задача.

#include <iostream>

using namespace std;

int main()

{

   setlocale(LC_ALL, "rus");

   

   int Q;

   cin >> Q;

   if (Q >= 100 && Q <= 999)

   {

       cout << "это 3-хзначное число";

   }

   else

   {

       cout << "это не 3-хзначное число";

   }

   cout << endl;

   return 0;

};

Вторая задача.

#include <iostream>

using namespace std;

int main()

{

   setlocale(LC_ALL, "rus");

   

   int D;

   cin >> D;

   if (D >= 10 && D <= 20)

   {

       cout << "Принадлежит";

   }

   else

   {

       cout << "Не принадлежит";

   }

   

   cout << endl;

   return 0;

};

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу вычисления суммы всех натуральных чисел, меньших м, в записи которых нет парных цифр. использовать функцию определения количества парных цифр в числе. язык c++
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Андреевич-Екатерина1974
Fedoseeva
romashka17-90
Ольга
Yevgenevich
demon8608
dubaiexport
Yevgeniya1807
Matveevanastya0170
elenabarskova7145
sssashago8
Коновалова1705
falileevas
romolga3580
TatianaSeliverstova64